C240 STOPPED MOVING WHILE IN

2004 Mercedes Benz

Tiny

seblani

May, 21, 2008 AT 11:27 PM

Engine Mechanical problem
2004 Other Mercedes Benz Models 6 cyl Two Wheel Drive Automatic 46000 miles

I have a 2004 C240 with exactly 46000 miles. I have been having occasional hesitation when I accelerate up hills for a couple of months. A couple days ago I broke down at a red light. The Check engine light came on and though the vehicle was in drive it wouldnt move. I towed it home and when I got home I put it in drive and drove about 200 feet and turned around put it in park and back in drive and at first it wouldn't move until I pushed the gas pedal hard and then it moved. My warranty expired last month. I am afraid of a HUGE repair bill, any advice on what the prob could be? Would a bad O2 sensor cause this?

FOUND 17083 RELATED QUESTIONS

2 Answers

Tiny

mhpautos

May, 22, 2008 AT 1:14 AM

Hi there,

This will not be a O2 sensor, your problem will be within the transmission. I would first get the scan done this may give the tech a better idea as where to start.

Mark (mhpautos)

Tiny

seblani

May, 22, 2008 AT 8:29 PM

Ok I got a scan done it said
p0715 input/turbine speed sensor A output
p0730 gear ratio incorrect

Does anyone have any idea what this means

Please login or register to post a reply.

How to read codes Chevrolet Blazer
How to gather codes Ford Explorer
Code Read Retrieval/Clear Scion XD
Code Read Retrieval/Clear
Code Read Retrieval/Clear Honda Civic
Code Read Retrieval/Clear Mercedes Benz