MERCEDES IGNITION PROBLEM

1985 Mercedes Benz 300sd

Tiny

scotthoman

July, 21, 2009 AT 11:15 AM

Electrical problem
1985 Mercedes Benz 300sd Two Wheel Drive Automatic 279164 miles

Turning key to " Start" does nothing. All I hear is a relay in the dash making a clicking sound and that may be when I turn the key to " Run" which is before " Start.&Quot; I have not changed any parts on the car. It started thousands of times without a problem prior to this. The battery still shows 12 volts roughly. There is no click from the starter or the selonoid. I am thinking of taking a closer look at the starter electrical connection but from what I saw when I crawled under there I didn't notice any obvious problems.

Does this car have a relay between the ignition switch and the Selonoid? If so where is it? I have checked all of the fuses and they look good. I spun them a bit in case there was some corrosion. I also took out each relay one a at a time to re-seat them in case of corrosion.

FOUND 1901 RELATED QUESTIONS

1 Answer

Tiny

Dr Loot

July, 25, 2009 AT 4:04 PM

First of all 12V is not enough capacity in your battery it should be showing at least over 13v have you tried giving it a jumpstart? And make sure you have a real set cables, or you will be wasting your time, if it starts up you have a bad battery, if it does not, you may have a bad starter, you can have someone in the car with the key on start, and hit the starter with a hammer, if it starts, you have bad starter.

Please login or register to post a reply.

Battery Replacement Ford Contour 1996-2000
Battery Replacement Ford Escape 2000-2006
Battery Replacement Honda Civic 2006-2011
Battery Replacement
Battery Replacement Guide