1995 Mazda 323 Miss fire

Tiny
SIDEMANTIES
  • MEMBER
  • 1995 MAZDA 323
  • 6 CYL
  • FWD
  • MANUAL
  • 116,000 MILES
My car broke down a few months ago and I replaced the distributor cap and rotary arm. She miss fires at low revs, high end revs and if I attempt to accellerate too fast. She struggles to pull off and will take a few attempts to build revs to p[ull off.
I have been reccomended to replace the MAF meter/sensor which I have done but we still have the same problems.
Are you able to offer any advice plaes?
Do you
have the same problem?
Yes
No
Wednesday, August 26th, 2009 AT 7:14 AM

4 Replies

Tiny
JACK42
  • MEMBER
Have you replaced the plugs and plug wires? The computer will have a hard time adjusting mixture if the basic tune up isnt in good working order
Was this
answer
helpful?
Yes
No
Wednesday, August 26th, 2009 AT 7:43 AM
Tiny
SIDEMANTIES
  • MEMBER
I have recently serviced the car and had plugs replaced and cables checked!
Could you reccomend some other parts to replace?
Was this
answer
helpful?
Yes
No
Wednesday, August 26th, 2009 AT 3:13 PM
Tiny
JACK42
  • MEMBER
Could be injectors. Pull the plugs to see if any one looks a different color than the rest. May even be a partially restricted exhaust, try loosening the pipe where it bolts to the manifold and see if it runs better, if so the cat converter is probably bad
Was this
answer
helpful?
Yes
No
Wednesday, August 26th, 2009 AT 3:37 PM
Tiny
CURMETT
  • MEMBER
Hey man, does it idle fine? Might pay to have someone check the vaccume advance. (As was the problem with my misfiring)
Was this
answer
helpful?
Yes
No
Friday, September 18th, 2009 AT 11:45 PM

Please login or register to post a reply.

Recommended Guides