Lost third and fourth gear

Tiny
TURBO BOB
  • MEMBER
  • 2003 CHEVROLET VAN
  • 5.3L
  • V8
  • 2WD
  • AUTOMATIC
  • 200,000 MILES
All of a sudden van works fine one day went out the next day to go to work and do not have third or fourth gear. Mechanic replaced transmission with a used transmission and still has the same exact identical problem. The new transmission that was installed had a neutral safety switch installed on it he said he was testing all of the pins at the computer and at the harness that the transmission and was showing low voltage from the ignition. So he is working on that now, but I just think what are the odds putting another the used transmission that was installed only had 90,000 miles on it and the converter looks brand new. The transmission was very clean and looked in good shape. The inside the pan was very clean really no metal shavings or fiber it seemed to be in pretty good shape. I mean what are the odds of it doing the same exact thing? It will shift in first to second perfectly fine then when it goes to shift into third it is like hitting neutral. It is the 4L60E transmission. I was just wondering if you had any ideas on where to go from here? Thanks so much Rob.
Do you
have the same problem?
Yes
No
Saturday, November 10th, 2018 AT 1:23 PM

1 Reply

Tiny
ASEMASTER6371
  • EXPERT
Good afternoon.

Make sure he verified power to the solenoids at the transmission.

Also, I would suggest having the transmission module flashed with new information as it is computer controlled. If he has a scan tool, he can download the information from the GM website and upload it to your van.

Roy
Was this
answer
helpful?
Yes
No
Saturday, November 10th, 2018 AT 1:46 PM

Please login or register to post a reply.

Recommended Guides