2006 Kia Rio ignition cyl misfire

  • 2006 KIA RIO

Engine Performance problem
2006 Kia Rio 4 cyl Two Wheel Drive Automatic 48000 miles

The dreaded check engine light came on.

First I just changed all spark plugs with some Bosch platinum plugs with no difference how it ran and no fix to the light. I bought a code reader, determined my engine check light was from a cylinder misfire #2. I replaced the ignition coil and the code remained for cylinder #2. I moved the new coil to cylinder #3 and the code moved to cylinder #3. I moved the new coil again to cylinder #1
and the code moved to cylinder #1. Bad new coil I thought so I returned it, put the original coil into cyl #1 and of course still the same code, misfire cyl #1. I finally got a new coil after a few weeks. Battery (the original) has gone flat so I jumped to start. Charged it for 30 min. Replaced the old coil in cyl #1 and still I have the misfire code. You can feel it is running rough at lower rpms especially.

During all of this time I didn't drive the car but to test it out when I put the new coils in.

After a couple of weeks the new coil arrived. This time I swaped the new coil to cyl #2 but the code remained on cyl #1. Maybe some deposits on the spark plug so lets try to burn them off with a quick mile drive. Resetting the code reader several times still showed the same code. Towards the end of the drive I wound it up to 5000 rpms for a block. This resulted in a huge loss of power and 2 new error codes. Multiple cylinder misfire and cyl #1 and #4 misfire.

What controls the coils?

Now it won't run at all. I can't even get out of the driveway. I've tried switching coils to move the problem, Put in a new battery but reving the engine has just flooded it or bogged it. It stalls out with my foot off the gas and it stalls out when I try to rev it. It only shows 1150 rpm max. No new codes at least.
Could I have damaged the harness, the condenser, can I check these?

Do you
have the same problem?
Sunday, September 27th, 2009 AT 11:11 PM

1 Reply


If the problem was moving with the coil, the coil was bad. However, now we have a new problem. Have you checked the crank sensor to make sure it is clean and working? That may be causing the problem. Also, the computer determines when you get spark to the cylenders. If you were not getting spark, you may have fouled the new plugs with fuel. Remove the plugs and check them. Also, check the crank sensor.


Was this
Monday, October 12th, 2009 AT 8:25 AM

Please login or register to post a reply.

Recommended Guides