Strange charge light issue

Tiny
BIGDADDYT
  • MEMBER
  • JEEP CHEROKEE
Hello all, my jeep is being a pain again. Here goes. 1985 jeep cherokee xj. 4 cyl. Auto 4wd. When the key is turned off the charge or battery light comes on. I end up with a dead battery. When the key is in the on position the light goes out and dosnt come back on until I turn it off. Once I jump it off it runs fine, no charge light. In fact, this led me to believe that the alternator is good, because once it is running the light5 goes off and the jeep runs fine for as long as I want it too, even when I use the headlights. The battery has been replaced. I realize I can have the alternator checked easily, I just have not had the time yet. When I was checking alternator prices on the advanced site, listed with the alternators was a statement that said that a blown fuse or bulb in the warning system could result in a no charge condition. HUH? Obviously the bulb is good since I am sick of looking at it, and if the fuse was bad then surely the bulb wouldnt light at all, right? Help please. Thanks for any suggestions.
Do you
have the same problem?
Yes
No
Sunday, September 9th, 2007 AT 2:06 AM

2 Replies

Tiny
M_H_RITZEL
  • EXPERT
After you check the altinator check to see if there is a problem with the ignition switch, when you turn off the key there should be no lights until you turn the key on. With the key off and you see the light check and see if any of the accesories work.
Was this
answer
helpful?
Yes
No
Sunday, September 9th, 2007 AT 10:07 AM
Tiny
GRICHARDS
  • MEMBER
I've been looking thru electrical schematics for 84/85 4 cylinders looking for a pathway that would take battery power to your battery indicator light with the key in the off position - Starting/Charging/Ignition, Engine Control, Gauge & Warning lights. The schematics probably aren't as detailed as needed, but on paper there is no logical path for electricity. Your battery light should only be lit with the key on On and Start, and all schematics show electricity going to a Dead-End inside the ignition switch with the key on the OFF position. I agree with M_J_RITZEL - with the key off, check your accessories (Radio, windshield wipers) - they should work in ACC and RUN only. If they DO work with the key OFF & removed, sounds like the ignition switch. Hope this helps!
Was this
answer
helpful?
Yes
No
Sunday, September 9th, 2007 AT 1:54 PM

Please login or register to post a reply.

Sponsored links