1997 Jeep Cherokee Grand Cherokee LID V8 - Bad BCM?

  • 3 POSTS

Electrical problem
1997 Jeep Cherokee V8 Four Wheel Drive Automatic 128xxx miles

My temp gauge goes straight to 260 once the key turns the ignition, where it stays until the key is turned off. Engine on or off, cold or warm, it remains at 260. Check Gauges light flashes. The Oil Gauge is starting to show slight movement when at idle it goes down a notch from 40 to 30, then back to 40 when accelerating. Sometimes the Battery Gauge moves slightly to the left of center

Other electrical issues include: intermittent wipers don't work, just slow/fast/off function. Side mirror and rear window defrost doesn't work. Rear wiper will make one "swipe" across the window then freeze. Cruise control doesn't work.

Parts that have been recently replaced are the radiator, thermostat and cooling sensor due to an overheat. The PCM was replaced due to other starting and electrical issues including intermittent "click" starts and moments of gauges and interior lights going crazy, clock reset and alarm arming itself. I tried a used gauge cluster and the gauge behavior occurred so I believe the gauges/cluster are ok.

Does this sound like a bad BCM? I thought it might be a grounded wire somewhere but another mechanic dismissed that idea due to how the computer buss system works.?

Do you
have the same problem?
Tuesday, December 15th, 2009 AT 3:54 PM

1 Reply

  • 68,494 POSTS

I think you need a priest rather than a mechanic. IT sounds posessed. However, it sounds like a bad BCM. It controls most everything you discussed. Get one from a salvage yard that is a direct fit to save money and just change it out with yours. Not a hard job. I feel that will fix the problems. Make sure the part numbers match.

Let me know if it helps.


Was this
Tuesday, December 15th, 2009 AT 9:07 PM

Please login or register to post a reply.

Recommended Guides