Jaguar s type radio

Tiny
TED OSTROW
  • JAGUAR

The display, controls and disc player appear to work but there is absolutely no sound.

The radio has a remote disc changer and what appears to be a power amp in the trunk.

The fault was once intermittent but now is consistent.

Can you advise how to remove the radio from its console?

Ted Ostrow

Do you
have the same problem?
Yes
No
Saturday, November 17th, 2007 AT 10:13 PM

7 Replies

Tiny
BMRFIXIT
  • EXPERT
  • 19,542 POSTS

Is it on mute due to cell phone use
check BCM for codes

Was this
answer
helpful?
Yes
No
-1
Saturday, November 17th, 2007 AT 11:45 PM
Tiny
TED OSTROW
  • MEMBER

Is it on mute due to cell phone use
check BCM for codes[/quote:086482485b]

Its not the mute feature. The radio just began working again today. I'm beginning to believe it might be an intermittent ground at the trunk-mounted power amp. I have no idea where to locate the ground connection though. Any info would be appreciated.

Ted Ostrow

Was this
answer
helpful?
Yes
No
Monday, November 19th, 2007 AT 9:14 PM
Tiny
BMRFIXIT
  • EXPERT
  • 19,542 POSTS

Is it on mute due to cell phone use
check BCM for codes[/quote:bd6c46fa08]

Its not the mute feature. The radio just began working again today. I'm beginning to believe it might be an intermittent ground at the trunk-mounted power amp. I have no idea where to locate the ground connection though. Any info would be appreciated.

Ted Ostrow[/quote:bd6c46fa08]

here what i have
make sure its not the switch s on steering


http://www.2carpros.com/forum/automotive_pictures/99387_jag_1.jpg



http://www.2carpros.com/forum/automotive_pictures/99387_jag1_1.jpg




http://www.2carpros.com/forum/automotive_pictures/99387_jag12_1.jpg

Was this
answer
helpful?
Yes
No
-1
Monday, November 19th, 2007 AT 9:32 PM
Tiny
TED OSTROW
  • MEMBER

To BMRFIXIT
Thanks for your prompt and helpful response. I attempted to leave you positive feedback on that site-feature, but it would not work.

I'll uncover the rear bulkhead and check the ground for continuity. Thanks again. Ted Ostrow

Was this
answer
helpful?
Yes
No
Tuesday, November 20th, 2007 AT 11:55 AM
Tiny
BMRFIXIT
  • EXPERT
  • 19,542 POSTS

Thank you for trying and I will let the boss know

Was this
answer
helpful?
Yes
No
Tuesday, November 20th, 2007 AT 12:56 PM
Tiny
FSTRANGER302
  • MEMBER

Hello, if the amp has gone bad the radio willnot have any sound. If you can get codes from the radio with a scanner, this will help, let me know thanks pat

Was this
answer
helpful?
Yes
No
Saturday, November 24th, 2007 AT 9:18 PM
Tiny
TED OSTROW
  • MEMBER

To: fstranger302

Thanks for your suggestion. The problem is intermittent and the radio is operating normally at this time. I believe the problem is an intermittent ground connection. Another member sent a wiring diagram showing the ground at the rear bulkhead. The drawing does not match my car, which is a 2003 model with fold-down rear seats.

I still have to remove the trunk liner to follow the wiring harness to a ground lug.

Thanks again. Ted Ostrow

Was this
answer
helpful?
Yes
No
Tuesday, November 27th, 2007 AT 11:49 AM

Please login or register to post a reply.

Other Radio Replace/Remove Questions