95 Accord. Speedo not working and auto trans warning

Tiny
RAB
  • MEMBER
  • 1995 HONDA ACCORD
Just bought a 95 accord in the philippines, 169k km. Had it a week and all was well but after I nudged a stone in a pothole(lots of those in the p.I)at only 5 or 10 km two things happened
first I noticed that the speedo was going crazy:up n down etc etc. Now it stays at zero most of the time
secondly the automatic transmission warning light came on and stays on
i've checked the fluid level and it's fine
i've looked under the car n yes u can see where the stone scored the floor but nothing badly bent or broken that I can see
i never had auto b4, always manual so i'm worried bout that warning light. But the car seems 2 drive ok. Again not being a previous owner of a car with auto trans i'm not 100% sure
what can I check because being a foreigner in the philippines leaves u wide open 2 get ripped off big time and I want 2 avoid that if at all possible
thanks in advance for any help u can give me
Do you
have the same problem?
Yes
No
Sunday, July 23rd, 2006 AT 2:21 AM

2 Replies

Tiny
BRUCE HUNT
  • EXPERT
Impact does strange things to cars, but look at the wiring to see if any wiring was damaged. Did you get a check engine light on as well? The sensor for the speedometer on the tranny could be either loose, disconnected or have failed.
Was this
answer
helpful?
Yes
No
Monday, July 24th, 2006 AT 9:21 AM
Tiny
RAB
  • MEMBER
The management light has come on a few times yes. From memory after travelling a longish distance. Say 25km or more. But other times no. Just the speedo reading zero and the auto trans warning after approx 2 or 3 minutes on the road
where is this vss on the tranny bruce?
If I could ever identify it i'll give it some attention n c if some tlc helps the problem. Lol
Was this
answer
helpful?
Yes
No
Tuesday, July 25th, 2006 AT 2:44 AM

Please login or register to post a reply.

Sponsored links