1988 GMC Truck Any connection between Transmission problem

Tiny
PJKUBAT
  • MEMBER
  • 1988 GMC TRUCK
  • V8
  • 2WD
  • AUTOMATIC
  • 131,000 MILES
Recently had the transmission reconstructed and I have gotten put back into my truck. Then the alternator didn't work, but it was original so I didn't question it and got it rebuilt. But then to test the transmission, I backed it out of the garage and found that now the brakes don't seem to work. Plus the engine won't idle down (which may be why the brakes aren't working right?). They look like original, but that's hard to believe and I wasn't having any problem with them before reworking the transmission. Is there something I should look at before going to the cost/time of replacing the brakes?
Do you
have the same problem?
Yes
No
Friday, May 15th, 2009 AT 7:27 PM

3 Replies

Tiny
DR LOOT
  • EXPERT
It sounds like the shops may have accidentally knocked off the vacuum line that is why the Idle won't go down and you have no brake booster assistance, check all of your vacuum lines make sure they are connected and not creaked or kinked.
Was this
answer
helpful?
Yes
No
Sunday, May 17th, 2009 AT 8:11 PM
Tiny
PJKUBAT
  • MEMBER
Thank you. We DID find that problem the next day, so you were right on.
Was this
answer
helpful?
Yes
No
Sunday, May 24th, 2009 AT 3:58 PM
Tiny
DR LOOT
  • EXPERT
I apologize it took so long to respond, I may have saved you a lot of time.
Was this
answer
helpful?
Yes
No
Sunday, May 24th, 2009 AT 4:06 PM

Please login or register to post a reply.

Recommended Guides