1996 GMC Sierra engine miss

Tiny
MATTHEW12
  • MEMBER
  • 1996 GMC C1500
I have a 1996 GMC Sierra 1500, Vortec 4300 engine, 5 spd standard transmission, 202500 km. Sometimes when it is wet and rainy or first thing in the morning until the engine warms up the engine will stutter a bit between 1,000 and 2,000 rpm. I have replaced the plugs and wires last week, and the distributor cap and rotor button were replaced last year (I had them out and they still look like new). It doesent feel like 1 cylinder is missing it feels like the whole engine is. However the engine light never comes on. Im wondering if it is either the coil, the oxygen sensor, or the EGR valve. If you could help me out with this it would be great. Thanks.
Do you
have the same problem?
Yes
No
Tuesday, May 15th, 2007 AT 5:08 PM

4 Replies

Tiny
JACK42
  • MEMBER
Have you ever had the injectors or fuel pressure regulator replaced? Those engines had problems with both, usually a problem in the A.M.
Was this
answer
helpful?
Yes
No
Tuesday, May 15th, 2007 AT 6:17 PM
Tiny
MATTHEW12
  • MEMBER
No I havent done either. I have only owned the truck for about 1 year and it had been well maintained before that.
Was this
answer
helpful?
Yes
No
Tuesday, May 15th, 2007 AT 7:42 PM
Tiny
MARC Z.
  • MEMBER
Was this
answer
helpful?
Yes
No
Wednesday, May 16th, 2007 AT 3:40 PM
Tiny
MARC Z.
  • MEMBER
[/quote:a498da4fdb]
Was this
answer
helpful?
Yes
No
Wednesday, May 16th, 2007 AT 4:01 PM

Please login or register to post a reply.

Recommended Guides