1995 GMC C1500 smog

Tiny
HK408
  • MEMBER
  • 1995 GMC C1500
  • V8
  • 4WD
  • AUTOMATIC
  • 235,000 MILES
1995 GMC k1500 P/U. I replaced o2 sensor, injectors, map sensor, air filter, plugs, wires, cap, rotor, fuel filter, fuel pump, oil, oil filter and the EGR valve. Compression, vaccume and timing are good. I cant get it to pass smog and the engine has a slight intermitten miss. I pulled the plugs and checked them and plugs 4, and 6 looked like they were running a little hotter than the rest. What might be causing the miss?

for the smog problem, my readings are as follows: at 15mph HC (PPM) measured 1910; max is 115 and GP limit are 332. At 25mph, HC(PPM) measured 1385; max is 92 and GP limit is 282. At 15mph, the CO% measured 1.75; max is 0.58 and GP limit is 1.88. At 25mph the CO% measured 1.24; max is 1.02 and GP limit is 2.32. At 15 mph NO(PPM) measured 415; max is 986 and GP limit is 1908. At 25mph, NO(PPM) meaesured 289, max is 846 and GP limit is 1708.

after replacing all of these things, what could be causing it to be THAT rich?
Do you
have the same problem?
Yes
No
Saturday, April 11th, 2009 AT 8:38 PM

1 Reply

Tiny
JERRYGOODWRENCH
  • MEMBER
The only thing that you missed was the fuel regulator. I've had to change a few of these for the same problem. Hook up a fuel pressure gauge, start eng, turn off, then watch gauge. If pressure drops a slight amount, thats normal but if it keeeps dropping then replace the regulator. If I remember right, this one is easy to change. Let me know.
Was this
answer
helpful?
Yes
No
Sunday, April 19th, 2009 AT 5:41 AM

Please login or register to post a reply.

Sponsored links