2003 Ford Windstar moving mystery

Tiny
RILEYRIDER
  • MEMBER
  • 2003 FORD WINDSTAR
  • 4 CYL
  • FWD
  • AUTOMATIC
  • 109,000 MILES
Hi, my van recieved 2 new front tires on sat. And then I drove it a couple of times over 24 hour period. I pulled into my garage at 4:30 and it was fine and when I went out at 10 to run errand. The van would not change gears. The parking light comes on when it's in park and the brake lights work when you put it into reverse. It hasn't been doing anything different lately except idle alittle too low, it hasn't stalled out but it sounded like it a couple of times.I had my "car guy" that just happens to live across the street and he checked tranny fluid and it was okay. So now we are perplexed, and confused. Although it probably is a coincidence about tires and tranny, but it would be better for me if they just knocked something off or something. Do you have any ideas what this could be? I like to have some sort of language of the possibilities so the garage doesnt get all technical on me. Thanks so much for your help!
Do you
have the same problem?
Yes
No
Tuesday, February 24th, 2009 AT 11:46 PM

1 Reply

Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi:
Try disconnecting the battery for about 10 minutes. See if that resets the computer. If it doesn't check to see if any body grounds have been disconnected. It sounds like maybe they bumpped a body ground strap. If no luck, have the body control module (BCM) checked. Disconnecting the battery should reset it, but there may be other problems with it.

Joe
Was this
answer
helpful?
Yes
No
Wednesday, February 25th, 2009 AT 11:50 AM

Please login or register to post a reply.

Recommended Guides