1997 Ford Taurus Poltergeist Radio

  • 1 POST
  • 1997 FORD TAURUS

1997 Ford Taurus 6 cyl 57,500 miles

So I recently purchased a 1997 Ford Taurus with 57,000 miles on it. It was originally a company car but when the company went out of business the car sat in a garage somewhere for a long time. Anyways about two weeks ago I noticed that the audio would cut out every time I put the car in reverse. More recently it's been doing the same in drive. But every time I put on the brakes or put the car in park or neutral the audio comes back in. It doesn't make any sense to me. It's not a loose wire and the fuses aren't blown. I took it down to autozone and all the morons there told me that they have no idea what it is and that my car must have poltergeist or that it may be a ground. My friend's dad said he thinks that it's my Neutral Safety Switch or something like that. I could really use a professional opinion though, but I don't have the money to waste on a mechanic that will just fool around or try to pull a fast one on me because I'm a girl. HELP!

Do you
have the same problem?
Monday, May 4th, 2009 AT 9:31 AM

1 Reply

  • 68,494 POSTS

Honestly it sounds like there is a bad ground. When additional power is used from another item, the radio is loosing its ground. There are body ground straps under the hood, the dash and car itself. Check them to make sure they are tight, not broken, and making a good connection. If all seems well, then have the body control module (BCM) tested.

Let me know what you find.

Was this
Wednesday, May 6th, 2009 AT 9:18 PM

Please login or register to post a reply.

Recommended Guides