RUNS ROUGH AND STALLS WITH NO ACCELERATION

1993 Ford Ranger

Tiny

JustJeremy

September, 21, 2009 AT 11:32 AM

Engine Performance problem
1993 Ford Ranger 6 cyl Two Wheel Drive Manual

If I unplug the mass air flow meter the engine will smooth out and run great, but if I reconnect the mass air flow meter it runs very rough and dies. I replaced the mass air flow meter and O2 sensors and still have the same problem. I even tried another mass air flow sensor and the problem continues. It runs very rich with the mass air flow sensor connected.

FOUND 4235 RELATED QUESTIONS

Running Rough

27 ANSWERS
34 IMAGES

Idles Rough/changed Ects

37 ANSWERS
3 IMAGES

2 Answers

Tiny

Jacobandnickolas

September, 21, 2009 AT 9:58 PM

Have you checked to make sure the catylatic converter isn't plugging? Also, have you checked the temp sensor?

Tiny

JustJeremy

September, 21, 2009 AT 11:29 PM

I did check the temp sensor as normal and also checked the catalytic converter as normal. I checked the readings of all other sensors and such with my Snapon scanner, they were all within specs. The other odd part of this is that when it is running rough there are no codes. I also ran the koer and koeo tests which also came up with no code and the MAF connected. With it disconnected, the only code I get is, of course, for the MAF. I have been a mechanic for 40 years now, own my own shop and always seem to be able to figure out a problem til now, Thanks for your help.

Please login or register to post a reply.

How to read codes Chevrolet Blazer
 Step by Step video GMC Yukon XL 2000-2006
Code Read Retrieval/Clear - Dodge Stratus
Code Read Retrieval/Clear Mercedes-Benz C230
Read Codes Like a Pro
How to gather codes Ford Explorer
Code Read Retrieval/Clear Mercedes Benz