1994 Ford Mustang Radiator issue

Tiny
CAL4EVER
  • MEMBER
  • 1994 FORD MUSTANG
  • V8
  • 2WD
  • MANUAL
  • 203,000 MILES
My car is leaking radiator fluid. Sometimes I will park and it will be fine. Other times I park and will come out to a big puddle under the car. Low coolant light keeps coming on. Also have a check engine light that keeps coming on - not sure if it is related. Fluid doesn't appear to be leaking out of the radiator itself - but appears about a foot behind that. I have tried some radiator stop leak stuff - no change. Someone suggested replacing the cap on the overflow tank - that maybe it isn't getting a proper seal. I haven't heard of that. Is it possibly the problem? What other suggestions do you have?
Do you
have the same problem?
Yes
No
Wednesday, August 20th, 2008 AT 5:51 PM

5 Replies

Tiny
ROB2008
  • MEMBER
I would suggest to fill the radiator with coolant and look exactly where its leaking from. Check for leaks around the radiator hoses and water pump.
Was this
answer
helpful?
Yes
No
Wednesday, August 20th, 2008 AT 6:19 PM
Tiny
MHPAUTOS
  • EXPERT
Hi there,

First thing to do is get a cooling system pressure test doe as this will pin point the leak for you, then have a scan done to identify the fault code causing the check engine light to activate, start here.

Mark (mhpautos)
Was this
answer
helpful?
Yes
No
Wednesday, August 20th, 2008 AT 6:21 PM
Tiny
CAL4EVER
  • MEMBER
Thanks for the advice - I'll give it a try. Not sure how much money I want to invest in a car with over 200,000 miles!
Was this
answer
helpful?
Yes
No
Thursday, August 21st, 2008 AT 12:44 PM
Tiny
CAL4EVER
  • MEMBER
I didn't get around to having the pressure test - kept driving and putting in fluid. Now the throttle appears to be stuck open as it revs very high when not in gear. Is it possible the leak was spraying the engine and has caused this new issue?
I'm taking it in to the shop in a couple days (I'm not driving it anymore) but I don't know much about cars (obviously!) And an trying to gain knowledge before getting 'taken' at the repair shop.
Your help is appreciated!
Was this
answer
helpful?
Yes
No
Tuesday, September 2nd, 2008 AT 6:39 PM
Tiny
MUSTANGAPRIL
  • MEMBER
Wow! Your '94 has over 200,000 miles! That's VERY high mileage for a '94.

I am having a similiar problem with the radiator. A friend had "found" the problem. A hose was not on properly but problem is they tried to reattach it and couldn't get it on fully so they used something else to bunch it up with so it fit properly. Now, it's leaking again! Lol

Could be just a hose as in my case.
Was this
answer
helpful?
Yes
No
Monday, September 8th, 2008 AT 10:15 PM

Please login or register to post a reply.

Recommended Guides