ENGINE PERFORMANCE PROBLEM2004 FORD FREESTAR 6 ...

2004 Ford Freestar

Tiny

HRThomas

August, 11, 2010 AT 10:40 AM

Engine Performance problem
2004 Ford Freestar 6 cyl Front Wheel Drive Automatic 89000 miles

my check engine light is on I have replaced plugs and wires and fuel filter and air filter but the light is still on it doesnt have any power and the engine light mostly flashes all the time I have also used several differant fuel injector cleaners and fuel sys cleaners but no help. What else I think is strange is that the air works really well but not at the moment it works real good but when you try to get on the gas it gets warm? I dont understand whats wrong, This may be a stupid question but would the battery have anything to do with this the reason I ask is early in the spring the battery went dead and I got one from a junk yard and its alot smaller than the original but it woks fine as far as starting the car which by the way starts good the engune doesnt sound like its running smooth kind of rough please help asap thank you

FOUND 4169 RELATED QUESTIONS

1 Answer

Tiny

rasmataz

August, 11, 2010 AT 3:50 PM

Have the computer scanned for code/s-you have a problem within the engine management system that caused the CEL to turn on-This is your starting point of diagnosis, finding out what's going on.

Please login or register to post a reply.

Cabin Air Filter Replacement Chevrolet Tahoe
Cabin Air Filter Replacement
Cabin Air Filter Replacement Porsche 911
Cabin Air Filter Replacement
Cabin Air Filter Replacement Honda Civic