Fluctuating speedometer

Tiny
DRJONEZ
  • MEMBER
  • FORD F-150
Hello. I own a '97 F-150 with 165000 km. It has a 4.6L V8, 4x4. My question is this:
A couple days ago, my speedometer started, for a lack of a better term, bouncing about 10 kph. So basically, when the gas is applied, or under load, the speedometer will read 100kph. When I take my foot off the gas, the speedometer will increase to read 110 kph before the deceleration of the truck is read, then back up about 10kph when I apply the gas again. It only started doing this over the last couple of days. I also noticed that if I put the truck into 4x4 mode, the speedometer reads true, with no fluctuation between a loaded and unloaded scenario.
Another thing, the OD light starts flashing after driving for a short time. This condition has been going on for a long time, and was told not to worry about it as long as the transmission will go in and out of OD, which it did, and still does.

Thank you. Donation is coming, but in a hotel away from home and have no secure connection, really.
Do you
have the same problem?
Yes
No
Wednesday, July 11th, 2007 AT 3:01 PM

6 Replies

Tiny
JACK42
  • MEMBER
Have the PCM scanned, it should have stored a code that will most likely lead to the fix for both the flashing light and the bouncing speedo. Then I would start with the Vehicle Speed Sensor
Was this
answer
helpful?
Yes
No
Thursday, July 12th, 2007 AT 8:20 AM
Tiny
DRJONEZ
  • MEMBER
OK. Exactly where would I find that and what will I need to replace it ie will I be able to do this myself
Was this
answer
helpful?
Yes
No
Saturday, July 14th, 2007 AT 10:38 AM
Tiny
JACK42
  • MEMBER
Yes you can do it. It is located on the left rear of the trans, or on the tailshaft of the transfer case. I would recommend a factory Ford part
Was this
answer
helpful?
Yes
No
Sunday, July 15th, 2007 AT 7:54 AM
Tiny
DRJONEZ
  • MEMBER
Hi there. I went to NAPA and bought a new speed sensor, had it installed and. Blah. Still doing the same thing. I now and officially getting worried. What would you recommend next (please don't say replace the transfer case) lol.

Do you have any recommendations at this time? Still looking forward to hearing back on this issue as I am now back home and have the ability and time to deal with this.

Thank you in advance.

That will be just my luck.

Look forward to reading your reply
Was this
answer
helpful?
Yes
No
Thursday, July 19th, 2007 AT 2:15 PM
Tiny
TONHENRY
  • MEMBER
Hello, I have basically the same problem with my 97 F150 4X4 4.6 185000 miles. Only my speedometer doesn't work but sometime it goes up to as high as 45 mph for a second or two. AZ shows P0500, speed control sensor, for mine. I was told it is located on top of rear differential on these models. Please let me know what worked to fix yours. At the moment I can't afford to buy more sensors than I have to.
Was this
answer
helpful?
Yes
No
Thursday, July 20th, 2017 AT 8:44 PM
Tiny
KEN
  • ADMIN
Hello,

Yes it does sounds like you have a speed sensor that is going out which is located and the rear of the transmission or transfer case.

Here are some diagrams so show you where the sensor is (below)

Please let us know if you need anything else to get the problem fixed.

Cheers, Ken
Was this
answer
helpful?
Yes
No
+1
Friday, July 21st, 2017 AT 11:45 AM

Please login or register to post a reply.

Recommended Guides