Ford Explorer engine installation.

Tiny
MRBECKHAM1978
  • MEMBER
  • FORD EXPLORER
I JUST RECENLY INSTALLED A REBUILT MOTOR INTO MY 98 FORD EXPLORER SPORT. (V6 4.0 SOHC), AND I'M HAVING A PROBLEM WITH THE #14 FUSE SLOT IN THE POWER DISTRIBUTION BOX UNDER THE HOOD. IT BLOW'S THAT FUSE EVRYTIME I CONNECT THE BATTERY. WHAT CAN THE PROBLEM BE?
Do you
have the same problem?
Yes
No
Saturday, January 6th, 2007 AT 11:15 PM

8 Replies

Tiny
CARUNDELL
  • MEMBER
Hey mr beckham,
what does the #14 fuse power up? It should state that in your owners manual or repair manual. Get back to me and I can help you more!

Chris
Was this
answer
helpful?
Yes
No
Sunday, January 7th, 2007 AT 6:26 AM
Tiny
MRBECKHAM1978
  • MEMBER
[quote="carundell"][quote="mrbeckham1978"]I JUST RECENLY INSTALLED A REBUILT MOTOR INTO MY 98 FORD EXPLORER SPORT. (V6 4.0 SOHC), AND I'M HAVING A PROBLEM WITH THE #14 FUSE SLOT IN THE POWER DISTRIBUTION BOX UNDER THE HOOD. IT BLOW'S THAT FUSE EVRYTIME I CONNECT THE BATTERY. WHAT CAN THE PROBLEM BE?[/Quote]

Hey mr beckham,
what does the #14 fuse power up? It should state that in your owners manual or repair manual. Get back to me and I can help you more!

Chris

The # 14 fuse in the power distribution box is for the generator/voltage regulator.
Was this
answer
helpful?
Yes
No
Sunday, January 7th, 2007 AT 11:24 AM
Tiny
MRBECKHAM1978
  • MEMBER
The # 14 fuse in the power distribution box is for the generator/voltage regulator.
Was this
answer
helpful?
Yes
No
Sunday, January 7th, 2007 AT 11:26 AM
Tiny
CARUNDELL
  • MEMBER
Interesting. I would start by electrically disconnecting the alt and see if the fuse still blows, if it does, then somewhere the harness is shorted. If not, then the alt is shorted (unlikely as it may seem)

Chris
Was this
answer
helpful?
Yes
No
Sunday, January 7th, 2007 AT 12:07 PM
Tiny
MRBECKHAM1978
  • MEMBER
Thank you man. I will try this asap. Thanks again
Was this
answer
helpful?
Yes
No
Sunday, January 7th, 2007 AT 12:10 PM
Tiny
CARUNDELL
  • MEMBER
My pleasure!

Chris
Was this
answer
helpful?
Yes
No
Sunday, January 7th, 2007 AT 12:26 PM
Tiny
MRBECKHAM1978
  • MEMBER
I tried all of the electrical outlets and even replaced the full line, and that didn't work. Do you think that the computer needs to be changed? It's the same exact motor?
Was this
answer
helpful?
Yes
No
Monday, January 8th, 2007 AT 1:33 AM
Tiny
MRBECKHAM1978
  • MEMBER
I finally got it to turn over now. Do you think that the computer needs to be reset? If so, what's the procedure?
Was this
answer
helpful?
Yes
No
Friday, January 12th, 2007 AT 1:36 AM

Please login or register to post a reply.

Recommended Guides