- CAR TROUBLES

1999 Ford Expedition

Tiny

amberlt83

September, 21, 2007 AT 12:25 PM

I own a 1999 Ford Expedition - Eddie Bauer - 4 wheel drive - 5.4 Liter:

I am having trouble passing emmissions. My car is also " lurching" when I start to go or hold it at a constant speed (especially 35 mph). I have also noticed pinging. I just had to replace the battery (not sure for what reason, old or what). If anyone has any suggestions as to what this could be or if you have had this problem I would really appreciate a response! Thanks!

PS - one of the emmission codes suggested EGR valve and said catalyst system not ready.

FOUND 1866 RELATED QUESTIONS

3 Answers

Tiny

wrench

September, 21, 2007 AT 12:39 PM

Is there any other codes, the EGR is by itself not working or working correctly would cause a failed test, if the vehicle is not warmed up then it will show the cat not ready (make sure its running long enough before test). Using high octane gas helps when time to test. If you have the print out of the failed test that could help in seeing whats going on. Im not sure if you are reading the failed test for codes or reading engine codes from a reader.

Tiny

amberlt83

September, 21, 2007 AT 2:13 PM

I don't have the sheet anymore, we just moved and I am unable to find it. However, we drove the car around for over 2 hours before we took it in. The " service engine soon" light is on and has been for a while, I heard this can cause failed emissions.

Do you have any idea what would cause the pinging, lurching, and reduced gas mileage (we are down to about 10 MPG)?

Thank you in advance!

Tiny

wrench

September, 21, 2007 AT 3:27 PM

To bad be nice to have the print out but still if you could get engine codes (if engine light on there should be codes in there) that would help.

Please login or register to post a reply.

Replace Your Transfer Case Like a Pro
4X4 Transfer Case Replacement Guide
Drive Shaft Removal - All Cars
Wheel Bearing Replacement
Wheel Bearing Hub Replacement