97 Ford Escourt LX speedometer and engine

Tiny
CYNNAMIN_KISSES
  • MEMBER
  • 1997 FORD ESCORT
Hello,

I just recently purchased this car, and since I've had it, it has been doing something odd.

This is my first car, I dont know alot about them at all :x But this is what it does.

When I get to 20Mph, my car putts (always). And sometimes, when I get to 50-70Mph, the car does this violent vibrating. If I am lucky, the car will stop once I speed up or slow down, but other times what will happen is the speedometer will "die" and go to 0 and it wont jump back up.

The only time I got it to jump back up was when I pulled over and shut the car off and turned it back on.

My father took it for a test drive, and again it outter at 20, then he went to 50, 60, 70, 80 and nothing happened. He tried switching gears. Nothin.

I don't know what im doing wrong. Someone told me it could be a loose connection in some wires.

Im also wondering if it is even the engine. Would it be the transmission instead? The car is an automatic and when its vibrating it makes me think that its switchin gears for some reason because also when it does this and the speedometer dies, I have to press a bit harder on the gas to keep it going.

Thanks for your help! :D
Do you
have the same problem?
Yes
No
Wednesday, September 26th, 2007 AT 8:24 AM

1 Reply

Tiny
RASMATAZ
  • MEMBER
For a start have the vehicle speed sensor check.
Was this
answer
helpful?
Yes
No
Wednesday, September 26th, 2007 AT 8:29 AM

Please login or register to post a reply.

Recommended Guides