1989 Ford E-Series Van Engin spits and sputters Idle issue

Tiny
JIM WBER
  • MEMBER
  • 1989 FORD E-SERIES VAN
Engine Performance problem
1989 Ford E-Series Van Two Wheel Drive Automatic 145K miles

I have a 1989 Ford E150 w/ a 302ci - 5.0 liter v8 3/spd-OD trans. 145,000 miles (45K miles since engine rebuild)
Over the last couple months, my engine will sputter periodically while driving and sometimes will stall in traffic when I stop. I restart the engine and drive away ok but sputter continues. It's most noticable at speeds at or below 45 mph. I also smell unburnt gas fumes and fuel mileage may be suffering too.

The engine light comes on until engine warms then goes out.

Also, sometimes when I come to a stop, my engine is still racing at high idle. When I hit the gas - as if to get the idle to come down - the engine races higher instead and have to hold the brake pedal hard. So, when I turn off engine and then restart, the idle is normal again.

Any ideas? Any recommendations? Thanks in advance.
Do you
have the same problem?
Yes
No
Thursday, November 4th, 2010 AT 2:14 PM

2 Replies

Tiny
RASMATAZ
  • MEMBER
Hi Jim Wber, Welcome to 2carpros and TY for the donation

Clean out the throttle plate-Check and test the idle speed control air bypass solenoid and the throttle position sensor-

Try extracting code/s from the computer
Was this
answer
helpful?
Yes
No
Thursday, November 4th, 2010 AT 3:43 PM
Tiny
JIM WBER
  • MEMBER
Where is the computer self check connector located? I know its under the hood. My engine compartment is very cramped and cannot find it.
Was this
answer
helpful?
Yes
No
Monday, November 15th, 2010 AT 3:30 AM

Please login or register to post a reply.

Recommended Guides