Battery light turns on and intermittent not starting issue

Tiny
DAVID SHELLER
  • MEMBER
  • 2009 KIA RIO
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 180,000 MILES
Okay, the battery light on my car comes on after I start it, but it is only dim not fully on. Sometimes it will go out while driving or if I leave it idle but not always. There are times the car wont start it will just crank as if it's not getting spark. Usually I can let it sit for a couple hours an it will start right back up. The battery is new. I am thinking it could possible be the crank sensor. Does anyone else have any insight or could possible guide me in the right direction? Thank you so much for reading.
Do you
have the same problem?
Yes
No
Saturday, January 25th, 2020 AT 6:34 PM

1 Reply

Tiny
KASEKENNY1
  • EXPERT
It is unlikely to be the crank sensor because that won't cause the battery light. It could be the issue with the not starting so if there are no codes. I would suggest trying it to solve the starting issue. However, the battery light is only triggered when the voltage of vehicle are below a minimum spec. We need to inspect the alternator operation for the battery light issue.

https://www.2carpros.com/articles/symptoms-of-a-bad-crankshaft-sensor

Let me know if you have questions but I would do those two things. Check for codes, if no codes, then replace the crank sensor. If there are codes that changes things. Then have the alternator load tested.

https://www.2carpros.com/articles/how-to-check-a-car-alternator
Was this
answer
helpful?
Yes
No
Sunday, January 26th, 2020 AT 3:34 PM

Please login or register to post a reply.

Sponsored links