Codes B1005, B1006, B1007, B1011 and B1140

Tiny
LOSTONIT
  • MEMBER
  • 2007 ACURA TL
  • 3.5L
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 228,000 MILES
No check engine light on however when scanned with scanner these electrical codes appeared. I noted them then cleared them out. They returned with still no check engine light on. The codes are b1005, b1006, b1007, b1011 and b1140 all mentioned Micu lost communication any chance Micu is bad?
Thank you
Do you
have the same problem?
Yes
No
Thursday, June 3rd, 2021 AT 6:50 PM

3 Replies

Tiny
KASEKENNY1
  • EXPERT
It is possible that it is a faulty control unit but each of these tests are asking you to clear the codes. Then check for other codes which you do not have and if not then you need to check for a loose connection at the MICU.

I would remove all the connection from the fuse box under the left side of the dash (the MICU is part of this) and then reconnect them. Clearly you should do this with the key off.

If the codes do not clear or return again then it says to replace the MICU.

Please see an example of this below. Please run through this and let us know what you find. Thanks
Was this
answer
helpful?
Yes
No
+1
Thursday, June 3rd, 2021 AT 7:08 PM
Tiny
LOSTONIT
  • MEMBER
Thank you for your help. The cost of the Micu was cheap so I changed it out.
It was a pain getting to back connectors but it s done problem solved. Now I ve got only on issue vsa light with exclamation is on, however no codes. Thank you
Was this
answer
helpful?
Yes
No
Wednesday, June 16th, 2021 AT 6:23 AM
Tiny
KASEKENNY1
  • EXPERT
That is great info. Thanks for coming back to update us and I am glad you solved the issue. That info will help others in the future.

We can help with the other issue if you need but let's get a new post started on that one so that others can find the solution if they have the same issue.

https://www.2carpros.com/questions/new

Thanks
Was this
answer
helpful?
Yes
No
Wednesday, June 16th, 2021 AT 7:40 PM

Please login or register to post a reply.

Sponsored links