Electrical

Tiny
SNOWDUST10
  • MEMBER
  • 1994 LAND ROVER
  • 4.2L
  • V8
  • 4WD
  • AUTOMATIC
  • 106,221 MILES
Started out with a flicker of darkness on my dash lights as I crossed the rr tracks. Next crossing I lost my dash lights permanently. When I got home I checked all fuses and found nothing. A couple days later all the sudden I have my traction control and abs lights on. Last night on my way home, there was a spark from the central area of the dash and the whole vehicle went dark and no response from the ignition switch. Battery is new leads are in good shape. Previous owner installed spring kit with lift so no more airbags. I took a hot wire and touched it to the white and white orange wires to start the vehicle with key
Do you
have the same problem?
Yes
No
Thursday, December 24th, 2015 AT 5:58 PM

3 Replies

Tiny
HMAC300
  • EXPERT
Check your ignition switch to see if it is sending power then check light switch also check ground and see if light switch has been turned all the way down to dim.
Was this
answer
helpful?
Yes
No
Monday, December 28th, 2015 AT 7:13 AM
Tiny
SNOWDUST10
  • MEMBER
Checked the light switch and there's power in and out all the way to the fuse box. The ignition switch has no power going out on the brown wire. I fused in a direct line from the battery with the brown wire and I now have power and it acts normal other than still no dash lights.
Was this
answer
helpful?
Yes
No
Monday, December 28th, 2015 AT 3:22 PM
Tiny
HMAC300
  • EXPERT
The schematic i'm sending is for a range rover and discovery 110. Check the brown wire with red stripe for power if it has none then it may be the dimmer for lights if it gets power to dash then check for burnt out bulbs.
Was this
answer
helpful?
Yes
No
Monday, December 28th, 2015 AT 4:15 PM

Please login or register to post a reply.

Recommended Guides