Check charging system warning

Tiny
EXPEDITION2003LC
  • MEMBER
  • 2003 FORD EXPEDITION
  • 5.4L
  • 2WD
  • AUTOMATIC
  • 142,000 MILES
Fixed the fuel pump relay with another douse box the alternator went out and had it replaced. Now it's saying check charging system and my rebuilt alternator isn't charging my battery and yet draining it. I've replaced fuses, relays only thing left I can think of to get the alternator to work, and the light on dash to stop. Is the box where the car battery is that wire or wondering if I have to reset my new fuse box an original computer system. Please help.
Do you
have the same problem?
Yes
No
Monday, June 6th, 2022 AT 6:50 PM

1 Reply

Tiny
JOE F
  • EXPERT
Hi,

For the alternator to produce power, it needs power. Have you checked at the alternator for power? At the alt connector, there is a black wire with an orange tracer. It should have 12v at all times. Please confirm that.

Additionally, fuse 9 in the central junction box (behind the right kick panel) sends power to the alternator via an orange wire with a light blue tracer. Check that as well.

Also, I attached the wiring schematic of the charging system below for your reference. I had to cut the pic in half to make it readable for you. I did overlap them so you can follow from one to the next.

Let me know.

Take care,

Joe

See pics below. (Charging system wiring schematic)
Was this
answer
helpful?
Yes
No
Tuesday, June 7th, 2022 AT 5:37 PM

Please login or register to post a reply.

Sponsored links