2001 Dodge Neon Radiatior

Tiny
DAUGHTRYSSUNSHINE
  • MEMBER
  • 2001 DODGE NEON
  • 4 CYL
  • FWD
  • AUTOMATIC
  • 133,670 MILES
I put antifreeze in the radiatior. The car sat in the driveway for 2 days. I then drove the car for 10 minutes. By the time I put the car in park at the house. All the liquid was gone. And it was a fingernail above the normal temp line and started to smoke. My cars temp gauge most of the time stays on the cold line. The heat also is not working! I just need to know where to start so I know what I need to get looked at to be fixed so the liquid stops dissappearing?
Do you
have the same problem?
Yes
No
Wednesday, December 3rd, 2008 AT 7:17 PM

7 Replies

Tiny
RASMATAZ
  • MEMBER
Started to smoke-What kind of smoke? Do you have a leak -it will show under the car if its leaking-give me more to work with right now were in a limbo here.
Was this
answer
helpful?
Yes
No
Wednesday, December 3rd, 2008 AT 7:34 PM
Tiny
DAUGHTRYSSUNSHINE
  • MEMBER
It was white smoke it only did it once hasnt since when I told you! Been checking the water and topping it off everytime I go to drive.
No I do not see anything leaking from the bottom of the car. Never really a puddle. Put some stop leak in a few months ago it seemed to work for a while. Put more in the other day hasnt been working at all.I was told by someone else it may be a head gasket that is lose. And the antifreeze is burning instead of circulating. I drive about 80 miles round trip a day. Does that help any?
Was this
answer
helpful?
Yes
No
Wednesday, December 3rd, 2008 AT 9:39 PM
Tiny
RASMATAZ
  • MEMBER
Get it block and pressure tested could be a headgasket, cracked head or block
Was this
answer
helpful?
Yes
No
Thursday, December 4th, 2008 AT 6:50 AM
Tiny
DAUGHTRYSSUNSHINE
  • MEMBER
Thank you for that. How bad is it if it is one of those things? Pretty bad like it would be better and less expensive to get a new car or reasonable? The car actually ran ok the antifreeze level was at normal both times I checked it and topped it off with water.
Sat in traffic for a little bit. And it barely got to the normal temp level. The oil isnt milky. No white fog coming out of the defroster and no white smoke coming out of the exhaust! I'm sorry I know nothing about cars and am kinda freaked out!
Was this
answer
helpful?
Yes
No
Thursday, December 4th, 2008 AT 4:57 PM
Tiny
RASMATAZ
  • MEMBER
Are you overheating and do you have white smoke coming out of the tailpipe?
Was this
answer
helpful?
Yes
No
Thursday, December 4th, 2008 AT 6:56 PM
Tiny
DAUGHTRYSSUNSHINE
  • MEMBER
No its not overheating because I keep topping it off with water everytime before I go to drive it. Today on the way back home from work was in traffic for a good 20 mins and it only got halfway to the normal line. When I got moving again at a normal speed it dropped back down to the cold line. No white smoke coming out of the tailpipe either?
Was this
answer
helpful?
Yes
No
Thursday, December 4th, 2008 AT 8:57 PM
Tiny
RASMATAZ
  • MEMBER
Replace the thermostat, the cooling fans are coming on -on time-if you have to keep topping it off its going somewhere. Earlier I suggested a block and pressure test-you might have to do this to get an idea what is really going on.
Was this
answer
helpful?
Yes
No
Thursday, December 4th, 2008 AT 9:03 PM

Please login or register to post a reply.

Recommended Guides