1998 Dodge Avenger Acceleration

Tiny
MAGRANT
  • MEMBER
  • 1998 DODGE AVENGER
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 14,200 MILES
I just changed the distributor and my car does not accelerate. I have to push the pedal all the way. It backfires, idles irradically, but eventually will get up to speed. I have no codes or engine light. It feels like the computer is not recognizing when I hit the gas. What could it be? Could it be a sensor? It feels like the engine is not getting fuel. The fuel filter is new.
Do you
have the same problem?
Yes
No
Tuesday, September 29th, 2009 AT 1:35 PM

1 Reply

Tiny
CH112063
  • MEMBER
Sorry about this no acceleration, but I would love to hear that it just started after I replaced distributor or I've tried replacing the distributor but it is still no good. No codes yet, but timing and valve timing are important, so I am going to consider that the new Mitsubishi distribuyor did not fix it. Hook up a fuel guage and bring the hose through the front of the hood and secure it under a wiper arm.
Backfiring and poor idle since dist. Replaced could be wrong distributor. One for turbo, other for non-turbo. Turbo computer needs to know number one. So a difference, is causing a riot in the computer which handles ign. And fuel. TPS, MAP, and coolant sensors also cause fuel didasters. Let the computer sit for a while with neg. Cable disconnected, then try it. If a crankshaft or camshaft sensor fails, just like the others they are monitored and will store a code unless the failure is too short. Needs more than a milisecond.
Check valve timing after battery disconnect for resetting the computer. The scan tool can moniter almost every sensor, the fuel guage will test that.
The catalytic converter could be clogged. That is another one that causes backfire. OK good luck.
Was this
answer
helpful?
Yes
No
Tuesday, September 29th, 2009 AT 10:29 PM

Please login or register to post a reply.

Recommended Guides