Climate Control Unit not working at all

Tiny
SAULT838
  • MEMBER
  • 2008 MITSUBISHI LANCER
  • 2.0L
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 204,000 MILES
My climate control unit isn’t working, but when I turn on my headlights the right interior lights on the unit turns on but none of the controls work. So I know that the actual unit is getting power. I changed and checked fuses multiple times and nothing works. Fan doesn’t turn on, defroster doesn’t turn on, no response from anything except from the interior lights.
Do you
have the same problem?
Yes
No
Tuesday, December 3rd, 2019 AT 9:14 PM

2 Replies

Tiny
KASEKENNY1
  • EXPERT
I suspect the control panel is the issue but we need to test voltage coming into the unit to make sure everything is there. Basically the AC ECU could be the issue but it appears that only sends signal to turn on or off at different settings and does not control the display which is where your issue is.

As you can see from the wiring diagram the power supply and interface circuit is interior to the control panel.
Was this
answer
helpful?
Yes
No
+1
Wednesday, December 4th, 2019 AT 8:25 AM
Tiny
SAULT838
  • MEMBER
Sorry for a late reply. But I went to the AC/heater ECU and I took it out to inspect it because I suspected that it was bad. I opened it up and it turns out the circuit board was fried, multiple burns throughout. So I ordered another unit and installed it. Now everything works again. Thanks for the help!
Was this
answer
helpful?
Yes
No
Saturday, December 14th, 2019 AT 8:34 PM

Please login or register to post a reply.

Sponsored links