Instrument cluster or some other electrical issue

Tiny
ZO2765
  • MEMBER
  • 2006 CHRYSLER TOWN AND COUNTRY
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 85,000 MILES
The premium instrument cluster with tachometer begins to flicker slowly then rather fast in the odometer number reading and transmission range indicator displays which is illuminated. It is followed by the gas, speed odometer, tachometer, rpm and temperature needle pointers all start malfunctioning up and down uncontrollably causing a warning beep to sound with brake and ABS warning lights blinking on/off non-stop for about three to seven minutes then returns to normal operation and starts again. Now the problem is getting worst because it is causing the radio/built-in navigation systems/AC to trip off/on and when I operate the power window switch/or turn signals the interior dome lights flicker as well. Would the instrument cluster be defective or is this some other electrical problem? The van runs well but for three days this electrical problem has started.
Do you
have the same problem?
Yes
No
Wednesday, September 8th, 2010 AT 10:18 PM

3 Replies

Tiny
MERLIN2021
  • EXPERT
What does the dealer you bought it from say? Will they fix it? This van needs to be scanned for B and U codes, or you will be just guessing. Have the dealer at least scan it for these codes.
Was this
answer
helpful?
Yes
No
-1
Thursday, September 16th, 2010 AT 2:05 PM
Tiny
BOBBIE HAMMOND
  • MEMBER
Okay, I did the trip reset gauges but it gave me a code saying E code. What does this mean? And also said 5 of 7.4.
Was this
answer
helpful?
Yes
No
Tuesday, May 15th, 2018 AT 2:21 PM
Tiny
KEN
  • ADMIN
The E is for error. The problem with the question above is the cluster was no good and needed to be replaced. I would reset the system by removing the negative battery cable for ten minutes and then reconnect it to see what happens.

Please report back.

Cheers, Ken
Was this
answer
helpful?
Yes
No
Friday, May 18th, 2018 AT 11:06 AM

Please login or register to post a reply.

Recommended Guides