2004 Chrysler Sebring Jumping and skipping on acceleration

Tiny
TIM380
  • MEMBER
  • 2004 CHRYSLER SEBRING
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 65,000 MILES
My 2004 Sebring has had this problem twice the second time was worse. As I'm driving the engine light comes on and about 20 minutes later the car skips and jumps as I try to accelerate, the car does just fine at idle, it only happens as I get to about 20 MPH ar am climbing a hill. The last time it did it and cleared up and the engine light went off. This time it did it for a lot longer.
Do you
have the same problem?
Yes
No
Sunday, August 1st, 2010 AT 6:38 PM

4 Replies

Tiny
RASMATAZ
  • MEMBER
Hi Tim380, Welcome to 2carpros and TY for the donation

Check engine light coming on

Go to Autozone supposely free service for the public and have the computer scanned for code/s-you have a problem within the engine management system that caused the CEL to turn on-This is your starting point of diagnosis, finding out what's going on. Get back with the OBD2 codes
Was this
answer
helpful?
Yes
No
Sunday, August 1st, 2010 AT 7:14 PM
Tiny
TIM380
  • MEMBER
No codes came up when device was attached.
Was this
answer
helpful?
Yes
No
Monday, August 9th, 2010 AT 2:10 AM
Tiny
TIM380
  • MEMBER
No codes came up when device was attached
Was this
answer
helpful?
Yes
No
Monday, August 9th, 2010 AT 2:13 AM
Tiny
RASMATAZ
  • MEMBER
I'm aware there's no codes-sometimes a parameter sensors or an actuator problem will not pop the CEL-normally we will think so but its not always the case

Check and test the crankshaft position sensor, manifold absolute pressure sensor and the throttle position sensor-won't hurt to check the fuel pressure.
Was this
answer
helpful?
Yes
No
Monday, August 9th, 2010 AT 2:17 AM

Please login or register to post a reply.

Recommended Guides