2004 Chrysler Sebring Headlights

Tiny
ARACHMAN
  • MEMBER
  • 2004 CHRYSLER SEBRING
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 11,800 MILES
When I turn on the headlights, the marker and tail lights come on but not the headlights. If I pull back on the lever the bright lights come on but stay on only as long as I hold the stem back. I have checked all of the fuses and they look good. I swiched the fuses with others and it did not help. I removed the "dual lever multifunction switch took it apart and cleaned the contacts. Put it back togeather and everything was the same, no head lights.
Do you
have the same problem?
Yes
No
Saturday, September 12th, 2009 AT 8:11 PM

3 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
Were you getting power to the multifunction switch?
Was this
answer
helpful?
Yes
No
+2
Monday, September 21st, 2009 AT 7:51 AM
Tiny
ARACHMAN
  • MEMBER
Thanks for replying to my question.
When I tested the contacts in the plug I found that power was there. But further concentration on the plug revealed that there is a faulty contact somewhere because if you apply pressure on one side of the plug while attached, the lights work. I played with it for an hour or so and dissambeled the multiswitch again but could not find the cause. I finally gave up and just reassembeled everything and inserted the end of a zip tie between the plug and the socket, in just the right spot, and it worked.
Not a very satisfying fix but it worked.
Was this
answer
helpful?
Yes
No
-1
Sunday, September 27th, 2009 AT 11:55 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
IT sounds like the plug itself is bad.
Was this
answer
helpful?
Yes
No
Sunday, September 27th, 2009 AT 7:22 PM

Please login or register to post a reply.

Sponsored links