2003 Chrysler Sebring I got a P0344 code

Tiny
JUNIOR37
  • MEMBER
  • 2003 CHRYSLER SEBRING
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 119,000 MILES
My car recently started surging once the car reaches 2400 rpms regardless of what gear I am in. I have changed the ignition coil and I have had new plugs and wires put in. I also noticed that when the ignition is in the on position my cruise control lights up like it should, but when I actually have the car running. There is no cruise light on the dash and it doesn't work. Any ideas would be helpfull
Do you
have the same problem?
Yes
No
Wednesday, April 23rd, 2008 AT 3:35 PM

5 Replies

Tiny
BMRFIXIT
  • EXPERT
You need to check and replace cam sensor


http://www.2carpros.com/forum/automotive_pictures/99387_camsensor_2.jpg

Was this
answer
helpful?
Yes
No
Saturday, April 26th, 2008 AT 9:34 PM
Tiny
JUNIOR37
  • MEMBER
Was this
answer
helpful?
Yes
No
Sunday, April 27th, 2008 AT 7:06 AM
Tiny
BMRFIXIT
  • EXPERT
And still have code p0344
you need to check the wiring harness
Was this
answer
helpful?
Yes
No
Sunday, April 27th, 2008 AT 7:58 AM
Tiny
JUNIOR37
  • MEMBER
Ok thanks but would you know exactly where I should start, or could it be anywhere in the wiring harness
Was this
answer
helpful?
Yes
No
Sunday, April 27th, 2008 AT 10:02 AM
Tiny
BMRFIXIT
  • EXPERT
Unplug cam sensor and check plug and wiring
using volt meter check for volts supply
check for a ground

Brown is ground (behind center of dash
blue/yellow is terminal #56 at the PCM
red is power and connect to injector wiring harness
Was this
answer
helpful?
Yes
No
Sunday, April 27th, 2008 AT 10:36 AM

Please login or register to post a reply.

Sponsored links