2005 Chrysler PT Cruiser Instrument cluster lights

Tiny
STEPHENW
  • 2005 CHRYSLER PT CRUISER

Electrical problem
2005 Chrysler PT Cruiser Front Wheel Drive Automatic 138000 miles

I have a 2005 PT, 138k kilometers on it. About a month ago I noticed that a section of the speedometer was dim and last week more of the instrument cluster lights went out, leaving me with maybe 2 lights and the high beam indicator light working. Into the dealer and after an hour and a half I’m told there’s bad news, it’s not just a matter of replacing burnt out bulbs but a whole panel is required at a cost of $650, not including labour. While they’ve ordered the part, the PT was returned to me with no instrument lights working, not even the high beam indicator. I’m not sure if the lights have any bearing on this, but subsequently I ran the self-diagnostic test which showed all the instrument dials moving properly, warning lights coming on, and no trouble code appearing. Does anyone have any thoughts on this? Does it sound plausible or should I be backing away from this dealer? Any advice would be much appreciated! Cheers, Stephen

Do you
have the same problem?
Yes
No
Sunday, January 20th, 2008 AT 10:26 AM

2 Replies

Tiny
JACK42
  • MEMBER

My software doesnt show anything as far as bulb replacement in the cluster, but the wiring diagram shows "illumination lamps" whether they are replaceable or not I m not sure.I dont understand why nothing works now, If you are a little mechanically inclined, I would remove the instrument cluster and look.

Was this
answer
helpful?
Yes
No
Monday, January 21st, 2008 AT 7:28 AM
Tiny
STEPHENW
  • MEMBER

Thanks, Jack. I'll try to pull things apart and see if the lamps can be replaced. I'll let you know. Cheers, Stephen

Was this
answer
helpful?
Yes
No
Monday, January 21st, 2008 AT 7:49 AM

Please login or register to post a reply.

Other Instrument Cluster Light Questions