2001 Chrysler 300 missing out

Tiny
MARK ZOSS
  • MEMBER
  • 2001 CHRYSLER 300
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 79,000 MILES
The motor will start missing out usually in the morning sometimes on start up and others times after you drive a couple miles. The check engine light comes on and will occasionly flash. Then all of the sudden it will run great and the light will go off. Usually for the rest of the day. A scanner reads coil #3 missfire coil when it does it. I replaced the coil and it still continues to do it. The mechanics that have worked on it are frustrated because it only does it for a few minutes then stops. They are guessing a ECM but hate to put on in on a guess. If you pull #3 coil wire while its missing out then put it back on it seems to fix it. But nothing can be found wrong with plug, wiring, or plug to ECM. Rain and outside temperature dont seem to be a factor. The injectors were replaced a year or so ago with rebuilt. Mechanic said he doesnt believe it is injector problem. Any help would be great I cant keep paying for scans that arent fixing the problem. Thanks
Do you
have the same problem?
Yes
No
Tuesday, September 22nd, 2009 AT 4:54 PM

1 Reply

Tiny
BMRFIXIT
  • EXPERT
We know its cylinder # 3 that is misfiring
you had the coil and plug replace at this point I would switch the injectors with a known good one
looking for the code to move with the injector and if so then we know its the injector
if that doesn't work and still cylinder # 3 that is misfiring
I would do a compression test 1st thing in the morning
Was this
answer
helpful?
Yes
No
Friday, September 25th, 2009 AT 8:30 PM

Please login or register to post a reply.

Recommended Guides