1993 Chevy Truck Running rough/Fuel

Tiny
RUBENROD
  • MEMBER
  • 1993 CHEVROLET TRUCK
  • V8
  • 2WD
  • AUTOMATIC
  • 128,000 MILES
Hello, I have a 3yr old re-built engine and have been running great up to a week ago it started to run very rough, to the point that while stopped at a light or turning slow with out having gas peddle accelerated the truck will turn off. It turns right back on, but also in one big notewhile in park just in idle it is missing very bad to the point that is shuts off. I had my son stay in the truck to keep the motor idling at a higher RPM and while I am looking at TBI carburator fuel injectors, I see that gas sprays a perfect gas injection to carburator, but I found that the reason motor is running very rough and like no power is that I see gas coming out of injectors and it stops and goes. It is not a constantspray of gas, so I thought that it would be the fuel filter and replaced it. Still same issue, so a friend of mine that works on my vehicle checked the fuel pressure and fuel pump in good also. Keep in mind, this is not all the time. Motor runs perfect for a while and out of no where if starts with the rough idle. Might be a sensor! I am fustrated at not finding the fix.
Do you
have the same problem?
Yes
No
Tuesday, May 27th, 2008 AT 8:02 AM

1 Reply

Tiny
PEAR69
  • MEMBER
First, you do not have a carburator--you have a throttle body and fuel injectors--TBI (throttle body injection). If the fuel sprays perfectly then you can probably rule out an injector problem. Check the TPS (throttle position sensor). However, considering the age and mileage of the truck you may wan to just get a complete throttle body rebuilt kit and install it.
This also could be an O2 sensor or a dirty EGR valve.
Was this
answer
helpful?
Yes
No
Friday, May 30th, 2008 AT 3:38 AM

Please login or register to post a reply.

Recommended Guides