1991 Chevy S-10 4.3 V6

Tiny
MARSHALL
  • MEMBER
  • 1991 CHEVROLET TRUCK
I have a 1991 S-10 170,000 miles my problem is when it gets hot it misses not at an idle just when your going down the highway and you press the gas to pass someone it is a stick.I changed the spark plugs, fuel filter, dis. Cap, rotor button, wires and coil the fuel pump is only about a year and a half old I at a dead end about what to do next please held Thank you, Marshall
Do you
have the same problem?
Yes
No
Tuesday, January 3rd, 2006 AT 9:50 PM

2 Replies

Tiny
MARSHALL
  • MEMBER
Yes I have no codes the check engine light has never came on.
Was this
answer
helpful?
Yes
No
Wednesday, January 4th, 2006 AT 8:41 PM
Tiny
CHUCK4788@COMCAST.NET
  • MEMBER
I have a simular problem that I can not resolve; hopefully someone will have an idea.
1989 Chevy S10 Blazer w/ 4.3 w/ 191,000 miles. Engine runs great except during hot idle. Engine must be fully warmed, eg after freeway driving, then the idle is slow and rough with what seems like an intermitent miss. During miss voltage drops, probably from slow engine speed and sometimes there is a surge after miss, ie: with light brake pressure car will creep.
No codes from ECM, rebuilt and flow tested thottle body, new EGR valve, fresh air cleaner. Replaced temperature sensor because ECM side quit, temp gauge read a little high with new sensor. New plugs, wires, cap and rotor about 20,000 mileas ago.
Thanks
Was this
answer
helpful?
Yes
No
Friday, January 6th, 2006 AT 4:31 PM

Please login or register to post a reply.

Sponsored links