1985 4.3 V6 - Chevy El Camino runs poor after 10 min

Tiny
ROGERBIRD
  • MEMBER
  • 1985 CHEVROLET TRUCK
I have recently broken a crankshaft and replaced it bearings and 2 damaged pistions and all piston rings.
after reinstallation of the engine, it would run poor.
After driving for10min, it will start skipping and try to stall.
Typically it will not log a code, unless it sucessfully stalls, then I get a 42 code. I have externally tested the Ign. Control module (EST), it tested fine, but since it seemed to be a heat issue, I have replaced it.
If I accelerate it will continue to run. The engine runs fine on cooler mornings or rainy days. I have cleaned the carbon out of the EGR valve.
Prior to the major engine work it was running good.
10 months ago I had replaced the Fuel Pump, Fuel Filter and both Fuel Injectors as well as the ECM - For a different issue.

Where do I go next?
Do you
have the same problem?
Yes
No
Wednesday, May 17th, 2006 AT 3:14 PM

3 Replies

Tiny
ROGERBIRD
  • MEMBER
I replaced the IGN control module (EST) and distributor cap, Still runs bad.
Finally took it to a Diag place. And every thing checked out fine, and their 'expert' opinion it has a bad fuel pump.

I had replaced the pump and filter last september, due to a full failure of the pump. Guess I go t a bad one, gonna try replacing it this weekend.

Let you know.
Was this
answer
helpful?
Yes
No
Thursday, May 18th, 2006 AT 4:38 PM
Tiny
ROGERBIRD
  • MEMBER
Well, I installed the new pump screen and filter.
Still runs poorly, Now it doesnt even take 10min.

Initial starting sometimes will surge at idle, 2000rpm down to 500rpm. If I restart or rev at 2000 for 20sec. It will run. I am getting intermittent Check engine lights (Code42) when it is running ok (ocassional misses) after a while it will begin to try to stall (and often does stall) and I will not get a code or a check engine light if that happens.

The Diag place, wants another $90 to 'begin again' since I replaced the pump and filter myself (instead of paying them $385).

It seems like I am fixing little cascading problems and never getting to the end.

Anyone have any I deas?

This is an '85 Chevy Elcamino V6 4.3L - Fuel Injected.
Have just replaced a broken Crankshaft+ bearings/#1+ 2 Pistions/ and all rings. - Less than 200 mi since replacement.
I have cleaned out the EGR valve, replaced the EST (ignition)Module and Distributor cap.

Roger
Was this
answer
helpful?
Yes
No
Monday, May 22nd, 2006 AT 2:59 PM
Tiny
ROGERBIRD
  • MEMBER
OK, I replaced the Fuel pressure regulator, now the car starts right away, still runs fine on cooler or damp days, and idles fine, but while driving randomly stalls, while still rolling, if I floor it, it will resume running (Dont have to turn the key) It will continue to run, typically it does not log a code. If it runs without stalling, I do get a check engine light that will blink on and off, and sometimes will stay on. (Guessing code 42 still). I am running out of things to change out. Does anyone have any ideas? What I should check?
Was this
answer
helpful?
Yes
No
Friday, June 2nd, 2006 AT 12:23 PM

Please login or register to post a reply.

Recommended Guides