S10 BLAZER BLACK SMOKING

1995 Chevrolet Trailblazer

Tiny

buellxb9rfb

October, 20, 2006 AT 7:50 PM

1995 s10 blazer
4.3 V6
171,000 miles

Truck has been balck smoking for weeks now. Took it to the shop and was told that I needed to have the MFI Injecter set replaced with a new one including a new fuel pressure regulator. Did that to day and the Darn thing is still black smoking and smelling real rich. Anyone know what else could be wrong. Maybe replace the plugs since it has been running like this for a while prior to replacing the MFI.
no Check engine light is on and computer not pulling any codes.
Thanks for the help : )

.
OKay so I pulled out the plugs and the were solid black so I cleaned them up and checked the gap to make sure it was.045 gm spec. Put them back in started it up ran fine no black smoke till after I drove it around and it warmed up to 195 came home put it in park and there it was the black smoe and rich smell. With a slight rough idle and I mean slight idle is right around 500 rpm 's any ideas.

FOUND 735 RELATED QUESTIONS

Black Smoke Coming From Exhaust

65 ANSWERS
100 IMAGES

Smoking

32 ANSWERS
48 IMAGES

5 Answers

Tiny

buellxb9rfb

October, 25, 2006 AT 9:45 PM

Indeed I check the map sensor with a volt meter and says that the volt meter should 4 - 5 volts when running and the volt meter read 0 - 1.3 and quickly back to 0 volts. According to the information from one of the dealers tec the map sensor is faulty. Black smoke=fuel white = water or coolant blue'ish = oil. And the cat is not clogged just had it replaced recently

Tiny

buellxb9rfb

October, 26, 2006 AT 9:44 PM

Well that didnt seem to fix it. Tomarorw I shall take it into the dealer and let them look they said over the phone that it sounds like I may need to have my computer reprogramed

Tiny

buellxb9rfb

October, 27, 2006 AT 3:21 PM

Okay one more question on this topic guys. I got desprite and took it to chevy, now they are telling me that my VCM vehical controll moduel is shorting out and that it is pulling code p0113 IAT sensor. They claim that this is what is causing my blazer to smoke and run rich. Does this sound like its true and would cause this problem. I just dont want to be out 600 bucks on a new computer if its not true.

Tiny

gm2mom

November, 29, 2010 AT 4:42 PM

My 93 Blazer was black smoke bad and bad smell. Everyone said it was the spider leaking. Replaced all the major sensors, replaced the bad vacume lines, it ran better, but still smoked. Pressure was good, replaced the spider, guess what? Still black smoke! Wasted $300.
It finally threw a code 43.
The knock sensor had been broken by someone at sometime and it was messing up everything. Please don't spend the money till you check out ALL of your other options. Now I have an old spider assbly that is still good with 97000 miles on it.

Tiny

buellxb9rfb

November, 29, 2010 AT 5:34 PM

Thankfully I didnt have to spend anymore on it cause someone hit me so hard it totaled it. Best day of my life

Please login or register to post a reply.

Replace Fuel Pressure Regulator
Fuel Injector Replacement Ford 5.4L V8
Valve Cover Gasket Replacement Toyota Corolla