My Cadillac is a Lemon

Tiny
CHERYLMCCORRY
  • MEMBER
  • CHEVROLET IMPALA
My first issue was that I had a P0171 and P0174 error codes. Which
Cadillac stated was my Catalytic Converters. They replaces those
which were still under warranty along with the fuel filter which cost
me about 70.00. Then after replacing the Converters my Check Engine
light came back on and when initially starting the Car it was chugging
like it was gasping for breath or fuel. So I take it back to Cadillac
and he says the code is now a P0300. Which he says are clogged fuel
injectors. So I had them run fuel injector cleaners through them
twice at $120.00 per shot and also they replaced the plugs and spark
plug wires. And he said if that doesn't work then they would have to
take the engine apart and manually clean the the heads at $2400.00.
The car is running better at least it is not chugging. But the CEL
came back on and when I just turn the key to Accessories it has this
winding sound just for about 30 seconds.

Can someone help me with this Lemon of a car I bought. I can't
believe Cadillac put their name on this car and won't do anything to
help you.

Cheryl
Do you
have the same problem?
Yes
No
Friday, January 6th, 2006 AT 12:26 PM

1 Reply

Tiny
CHERYLMCCORRY
  • MEMBER
Follow up:

Sorry I have a 2000 Cadillac Catera V6 3.0. I just took it back to Cadillac yesterday because CEL is still on and he said it is still the same code P0300. The valves are not opening and closing. He says I might want to try an Oil Thinner. I always use 5w30 Castrol oil. When I was driving to the store last night there it goes and CEL :x comes back on at about 35mph. I can't afford to put 2500.00 into this car for them to clean the heads. When I intitially spoke to someone when this all started he said it might be the Mass Airflow Sensor. Could that cause the valves not to open and close. I don't want to damage the engine by continuing to run it. Also I think when I had my mechanic run the fuel injector cleaner through it the first time and it did not help so then he ran it through again and replaced the plugs he might have turned the idle up so it wouldn't die. Last night I noticed when it is in Park the engine revs up to 2000rpm all by itself. If I put the brake on it comes back down to 1. Please help me. ?
Cheryl :cry:
Was this
answer
helpful?
Yes
No
Saturday, January 7th, 2006 AT 11:25 AM

Please login or register to post a reply.

Sponsored links