Chevy Impala and EGR issues

Tiny
AABT45
  • MEMBER
  • CHEVROLET IMPALA
I have a 2003 Chevy Impala with 115K miles. 3.4L v-6. My check engine light came on. I found that it was related to the EGR valve. I purchased and replaced the EGR valve and had the check engine light reset. Immediately upon driving the vehicle, the check engine light came back on.

I continued to drive the vehicle for approximately 5K miles after being told this would not harm my vehicle. Now I am experiencing acceleration problems. When going uphill I can be going 70mph at the bottom of the hill, by the top of the hill my speed decreases to 50mph and I am trying to accelerate.

Any suggestions on what my problem might be?
Do you
have the same problem?
Yes
No
Monday, November 12th, 2007 AT 5:30 PM

3 Replies

Tiny
MERLIN2021
  • EXPERT
On the side(s) that are locked up, open the bleeder screw, does the rotor spin? If yes the brake hose needs to be replaced, But to make sure. When you have the lock-up, unbolt the Master from the booster first, check for spin, if no spin, open bleeder, if you get spin the push rod adjustment is off on the master, This is rare! Usually the hose.
Was this
answer
helpful?
Yes
No
Saturday, September 1st, 2007 AT 6:40 AM
Tiny
BMRFIXIT
  • EXPERT
Egr not the problem
After replacing the EGR u said engine light came back right away
Did u check what the code?
If u reset the ECM and if its not a hard failure u have to go throw two drive cycle for the ECM to determine EGR problem
Get the code and lets see what is going on
wiring
mass air flow sensor
cat
good luck
Was this
answer
helpful?
Yes
No
Monday, November 12th, 2007 AT 7:36 PM
Tiny
DENNYP
  • EXPERT
Have the vehicle scanned for codes again, and let us know what the code numbers are. That will give us a better idea of what the problem is.
Was this
answer
helpful?
Yes
No
Tuesday, November 13th, 2007 AT 6:45 PM

Please login or register to post a reply.

Recommended Guides