2003 Chevy Impala

Tiny
JERMAI07
  • MEMBER
  • 2003 CHEVROLET IMPALA
2003 Chevy Impala V8 Automatic 100000 miles

I have a 2003 chevy impala. My car has leaks coolant and get hot. I got my head gasket replaced and I drove it and it sounded like a motorcyle engine. The car still gets hot and I saw a leak near the water pump. My car went to the off position while I was driving so I had to turn back to the on position. Can you tell me whats wrong with my car?
Do you
have the same problem?
Yes
No
Monday, September 21st, 2009 AT 12:31 PM

11 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
I need you to check something. On the water pump, there is a weep hole. Is is aprix 1/4" in diameter. Check to see if that is where the coolant leak is coming form.

Exactly what size engine is in the car?
Was this
answer
helpful?
Yes
No
Monday, September 21st, 2009 AT 10:00 PM
Tiny
JERMAI07
  • MEMBER
I made a mistake on the type of engine, it is a v6. The engine size is 3.8 and yes it almost that size coming from the watere pump.
Was this
answer
helpful?
Yes
No
Tuesday, September 22nd, 2009 AT 9:39 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Did you check the weep hole on the pump?
Was this
answer
helpful?
Yes
No
Tuesday, September 22nd, 2009 AT 10:15 AM
Tiny
JERMAI07
  • MEMBER
Yes I checked the weep hole in the pump.
Was this
answer
helpful?
Yes
No
Tuesday, September 22nd, 2009 AT 11:32 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Was there any evidence of a leak?
Was this
answer
helpful?
Yes
No
Tuesday, September 22nd, 2009 AT 1:33 PM
Tiny
JERMAI07
  • MEMBER
The whole and leak has been fix but it still overheats and has a clicking noise. Can you tell what is it now?
Was this
answer
helpful?
Yes
No
Friday, September 25th, 2009 AT 1:04 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
HAs the thermostat been replaced and the cooling system serviced? If so, and it continues to overheat and the fans are working, have the head gaskets checked. You will need to have compression tested.
Was this
answer
helpful?
Yes
No
Friday, September 25th, 2009 AT 1:36 PM
Tiny
JERMAI07
  • MEMBER
The thermostat was replaced before I got a new head gasket put on. Could it be that the head gasket wasnt put on properly? My car is currently in the repair shop so here is my number (804) 451-5300 and if you need to contact the shop personally to ask question here is there number (804) 458-0880 or (804) 452-0444.
Was this
answer
helpful?
Yes
No
Saturday, September 26th, 2009 AT 11:58 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi:
The only thing left is a plugged radiator or something was done wrong. However, considering it is doing the same thing, I would say the same problem still exist. Thus, the head gasket didn't fix it.

Wait to see what they say on Monday. It's 12:47AM here so I can't call at this time. Let me know what you find out.
Was this
answer
helpful?
Yes
No
Saturday, September 26th, 2009 AT 11:47 PM
Tiny
JERMAI07
  • MEMBER
Will getting my motor replaced with another motor fixed this problem?
Was this
answer
helpful?
Yes
No
Monday, September 28th, 2009 AT 5:02 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Not if the radiator or cooling system is plugged. I would have that checked. You may need to "rod out" the radiator because a regular flush may not do it.
Was this
answer
helpful?
Yes
No
Monday, September 28th, 2009 AT 9:10 PM

Please login or register to post a reply.

Recommended Guides