1996 Chevy Camaro O2 sensor

Tiny
JMRAYFIELD
  • MEMBER
  • 1996 CHEVROLET CAMARO
  • V8
  • 2WD
  • AUTOMATIC
  • 123,000 MILES
I HAVE REPLACED THE SAME O2 SENSOR TWICE IN ONE WEEK. I HAD MY CAR CODED. THE SCANTOOL SAID BANK 1, SENSOR 2; NO ACTIVITY. I CHANGED IT. THE CAR WENT ABOUT 50 MILES THEN THE CHECK ENGINE LIGHT CAME BACK ON. I HAD IT CODED AGAIN. THE SAME CODE POPPED UP. I CHANGED THAT SENSOR AGAIN AND HAD THE CODE CLEARED. I DROVE IT AND SURE ENOUGH AFTER 50 MILES OR SO THE LIGHT CAME BACK ON. I HAD IT CODED AND THAT SAME CODE CAME UP. I HAD IT CLEARED AGAIN BUT DIDN'T CHANGE THE SENSOR FOR A THIRD TIME. I DROVE IT MORE AND BEFORE THE DAY WAS OUT THE CHECK ENGINE LIGHT HAS CAME BACK ON AND I'M GUESSING IT'S BANK 1, SENSOR 2; NO ACTIVITY. I'M LOST AND HAVE NO DEFINITE IDEA OF WHAT COULD BE WRONG. WHAT DO YOU THINK? THANK YOU.
Do you
have the same problem?
Yes
No
Saturday, March 8th, 2008 AT 11:20 PM

14 Replies

Tiny
MASTERTECHTIM
  • MEMBER
You are replacing the o2 behind the converter? The last one. Is there any exhaust leaks?
Was this
answer
helpful?
Yes
No
Sunday, March 9th, 2008 AT 3:41 PM
Tiny
JMRAYFIELD
  • MEMBER
YES. TO THE BEST OF MY KNOWLEDGE THERE ARE NO LEAKS. I FOUND THAT ONE OF THE 4 WIRES IN THE SOCKET COMING FROM THE CAR ( PURPLE WITH WHITE STRIPE) HAD NO READING ON MY OHM METER. IT WAS ACTUALLY FALLING OUT THE BACK OF THE SOCKET WHEN I PLUGGED IN THE O2 SENSOR. I BYPASSED THE SOCKET ALL TOGETHER. I UNHOOKED THE POSITIVE BATT TERMINAL AND MY SERVICE ENGINE LIGHT WENT OFF BUT LATER CAME BACK ON. DOES MY COMPUTER KEEP THESE CODES IN MEMORY UNTIL I HAVE THEM CLEARED BY A SCAN TOOL? WILL MY COMPUTER DETECT THE REPAIR AND TURN THE LIGHT OFF BY ITSELF? OR DO I STILL HAVE A PROBLEM? I KNOW VERY LITTLE ABOUT THE OBD2 IN MY 96 Z28. ANY HELP WOULD BE GREAT. THANKS.
Was this
answer
helpful?
Yes
No
Tuesday, March 11th, 2008 AT 9:35 PM
Tiny
MASTERTECHTIM
  • MEMBER
If it went out and came back on then you still have a problem. Exactly which o2 sensor are you replacing? Describe to me where it is. What is the code number that you are getting. We will get this light out.
Was this
answer
helpful?
Yes
No
Wednesday, March 12th, 2008 AT 7:00 AM
Tiny
JMRAYFIELD
  • MEMBER
I AM REPLACING THE DOWNSTREAM O2 SENSER ON BANK 1. THE CAT ON THE DRIVERS SIDE PIPE IS ALMOST DIRECTLY NEXT TO THE OIL PAN. THERE ABOVE IT IS O2 SENSOR 1. THE SENSOR THATS CAUSING ME SUCH TURMOIL IS THE ONE PAST THE CAT. THE EXHAUST CURVES TO THE PASSENGER SIDE WHERE BOTH PIPES WILL RUN BACK TO THE MUFFLER. SENOR 2 ON BANK 1 IS LOCATED VERY CLOSE TO THE PASSENGER SIDE FENDERWELL. I TRACED THE WIRING FROM IT VERY EASILY. THEY GO OUT FROM THE SENSOR AND DIRECTLY UP THE FENDERWELL TO THE COMPUTER. I HAD THE CODE CLEARED FROM ITS MEMORY YESTERDAY BUT THIS MORNING THE LIGHT CAME BACK ON AGAIN. THE CODE READS " P0140 O2 SENSOR CKT NO ACTIVITY (BANK 1 SENSOR 2) ". AS I SAID BEFORE I'VE REPLACED IT TWICE, REPAIRED 1 OF THE WIRES THAT WAS FALLING OUT OF THE CARS SOCKET BY BYPASSING THE SOCKET, AND LAYED UNDER THE CAR AND MONITERED THE READINGS ON MY OHM METER TO MAKE SURE THERE IS A GROUND AND ALL WIRES HAVE A CURRENT. I HAVE 2 BOYS AND THEREFORE IT MAKES PAYING A DEALERSHIP OR A MECHANIC $70 AN HOUR VERY DIFFICULT. I HOPE YOU CAN HELP ME. THANK YOU.
Was this
answer
helpful?
Yes
No
Thursday, March 13th, 2008 AT 2:40 PM
Tiny
MASTERTECHTIM
  • MEMBER


http://www.2carpros.com/forum/automotive_pictures/139033_o2_1.jpg

key on engine off check voltage from ground to each of the signal wires and see if you have 4.5 volts with the o2 unplugged. im not sure which signal wire is the one with 5 volts so compare it with bank 2 to be sure and lets start out by seeing if we have the right voltages. then without a scan tool you can use a multimeter to watch the o2 voltage. it should go from above and below 5 volts. get back to me
Was this
answer
helpful?
Yes
No
Thursday, March 13th, 2008 AT 4:27 PM
Tiny
JMRAYFIELD
  • MEMBER
YOUR WIRING DIAGRAM AND OTHERS I'VE LOOKED AT IN THE PAST FEW HOURS SHOW THAT I SHOULD SEE A DARK BLUE WIRE AND GREY WIRE. BUT FOR SOME REASON THE WIRES I'VE BEEN FOOLING WITH MATCH THE COLORS FOUND ON SENSOR 1 ON BANK 1. I'M GOING TO HAVE TO MAKE DOUBLE SURE I'M WORKING ON THE RIGHT SENSOR. I'M SURE I AM THOUGH. I NEED BANK 1, SENSOR 2.
Was this
answer
helpful?
Yes
No
Friday, March 14th, 2008 AT 6:41 PM
Tiny
MASTERTECHTIM
  • MEMBER
That would explain our problem. Get back to me
Was this
answer
helpful?
Yes
No
Saturday, March 15th, 2008 AT 6:00 AM
Tiny
JMRAYFIELD
  • MEMBER
ALRIGHT I WAS WORKING ON THE RIGHT SENSOR. THE COLORS OF THE WIRES DONT MATCH ANY DIAGRAMS.? ANYWAY I CHECKED THE VOLTAGE (KEY ON ENGINE OFF) ON B1, S2 WIRES AND B2, S2 WIRES. THE RESULTS WERE 1 WIRE ON BOTH SENSORS READ 10-12 VOLTS, ANOTHER READ 2-4 VOLTS. THE GROUNDS WORKED WELL OBVIOUSLY. HERE'S WHERE I FOUND A PROBLEM. B2, S2 HAS A SOLID PURPLE WIRE THAT READ 4-5 VOLTS. B1, S2 HAD A PUR/WHT STRIPE WIRE THAT READ NOTHING. I UNBOLTED AND PULLED OUT THE PCM. THEN REMOVED THE TAPE AND CORRUGATING FROM ALL WIRES. I TRACED THE PUR/WHT WIRE TO THE PCM AND TOOK A READING. STILL IT READ ZERO. I THEN TRACED THE PUR WIRE AND GOT A READING OF 4-5 VOLTS. I CHECKED THE PRONG AND WIRE INSIDE THE HARNESS. OTHER THAN A LITTLE PULL ON THE WIRE, THE PRONG WAS LOCKED IN PLACE AND MADE A GOOD CONNECTION TO THE PCM. IT LOOKS TO ME THAT THE PCM IS NOT TRANSMITTING TO B1, S2 BUT IS TO B2, S2. COULD I SPLICE THE 2 TOGETHER? B2, S2 IS LOCATED WHERE THE 2 PIPES COME TOGETHER WHILE B1, S2 IS UNDER THE ENGINE. I THINK IT WOULD WORK FINE THIS WAY AND KEEP THE LIGHT OFF. DOERS MY PCM NEED TO BE REPLACED? WHAT DO YOU THINK? LET ME KNOW. THANKS.
Was this
answer
helpful?
Yes
No
Saturday, March 15th, 2008 AT 6:07 PM
Tiny
MASTERTECHTIM
  • MEMBER
Wow you did your homework. I definitely would jump off the other wire and share the 5 volt reference. It cant hurt. The only other thing is if the purple wire is shorted to ground that would give you the 0 volts so first I would cut the purple and white wire at about 3 inches from the pcm then check for voltage, if its still nothing then jump the other wire. Definitely let me know how you make out.
Was this
answer
helpful?
Yes
No
Saturday, March 15th, 2008 AT 6:23 PM
Tiny
JMRAYFIELD
  • MEMBER
ALRIGHT I'LL CHECK THAT WIRE. FROM WHAT I'VE LEARNED AN O2 SENSOR WILL ONLY EXCHANGE SIGNALS WITH PCM EVERY SO OFTEN (AT THE VEHICLES NORMAL OPERATING TEMP AND EVERY 50 MILES AFTERWARDS....I THINK) SO I WON'T KNOW ANYTHING UNTIL MONDAY IF IT'LL WORK. I'M MOSTLY SELF TAUGHT EXCEPT FROM THE GUIDANCE AND TEACHINGS FROM MY FATHER AND AND UNCLES WHICH ARE AUTO ENTHUSIASTS. I'M JUST 23 SO YAH I STILL ASK DAD. BUT EVERYONE WAS STUCK ON THIS ONE. I WAS HOPING YOU WOULD AGREE WITH ME BECAUSE I'VE ALREADY RUN THE TWO TOGETHER. : ) SO FAR SO GOOD. THE LIGHT IS OFF FOR NOW. I CUT THE WIRE U SPOKE OF AND LEFT ABOUT THAT AMOUNT( 3 IN) INTACT. I'LL CHECK THAT ASAP. THANK YOU.
Was this
answer
helpful?
Yes
No
Saturday, March 15th, 2008 AT 7:02 PM
Tiny
JMRAYFIELD
  • MEMBER
I CHECKED THE WIRE YOU INSTRUCTED ME TO AND IT STILL READ READ NOTHING IN VOLTAGE OR OHMS. I WAS INCORRECT ON ONE STATEMENT. THOSE 2 WIRES READ NOTHING ON VOLTAGE, BUT ONE(SOLID PUR) WILL READ WELL ON THE OHM SETTING. MY METERS LOWEST SETTING IS 1-10 VOLTS ON THE VOLTAGE SETTING. THE LIGHT DID COME BACK ON TODAY. I HAD IT CODED AND IT SAID COMETHING I HAVEN'T SEEN BEFORE. ORIGINALLY THE PRINTOUT WOULD READ "DTC CODES P0140 O2 SENSOR CKT NO ACTIVITY BANK 1 SENSOR 2". BUT TODAY IT SAID " SET DTC CODES HISTORY DTC P0140 O2 SENSOR CKT NO ACTIVITY BANK 1 SENSOR 2 MIL REQUESTED SINCE IGN NOT RUN SINCE CLEAR FAIL". THEY SAID THAT IT LOOKS LIKE MY PCM WAS JUST PULLING A CODE FROM ITS MEMORY SINCE THE HEADING SAID 'HISTORY DTC.'. SO I HAD THEM TO ERASE THE CODE FROM ITS MEMORY. I MADE A CHANGE ON THE WIRING. I NOW HAVE BOTH DOWNSTREAM SENSORS WIRED TOGETHER COMPLETELY. WHAT I'M ATTEMPTING TO DO IS FOOL MY PCM. I HAVE ALL THE WIRES HOOKED TOGETHER TO SEND A SIGNAL TO THE PCM FOR B1, S2 AND B2, S2 BUT WHILE USING B2, S2 AS THE POWER SOURCE. I'M TRYING TO EXPLAIN AS BEST AS I CAN. I APOLOGIZE IF I'M MAKING THIS CONFUSING. BASICALLY I HAVE THE PUR AND PUR/WHT WIRES TWISTED TOGETHER CLOSE TO THE PCM. THEN I HAVE 1 WIRE THAT RUNS TO THE PUR WIRE HANGING OUT OF THE PCM THAT IS FOR B2, S2. I THEN HAVE A WIRE TWISTED TO THAT AND IT RUNS OVER TO THE PUR/WHT WIRE HANGING OUT OF THE PCM THATS FOR B1, S2. NOW BOTH THE PUR AND PUR/WHT WIRE ARE READING ON MY METER IN OHMS AS WELL AS VOLTS FOR THE OTHER WIRES. DO YOU THINK THIS WILL WORK? YOU NEVER ANSWERED ME BEFORE ON DO YOU THINK MY PCM IS FAILING, IS THE PROBLEM? LET ME KNOW WHAT YOU THINK ON THOSE TWO. THANKS.
Was this
answer
helpful?
Yes
No
Sunday, March 16th, 2008 AT 8:22 PM
Tiny
MASTERTECHTIM
  • MEMBER
Pcm is definitely no good because of the no output on the purple wire. I think what you are doing will work. Im not positive it will, but confident.
Was this
answer
helpful?
Yes
No
Monday, March 17th, 2008 AT 12:01 PM
Tiny
JMRAYFIELD
  • MEMBER
WELL MY IDEA FAILED. THE LIGHT CAME BACK ON THIS MORNING ON MY WAY TO WORK. I'M GOING TO GO AHEAD AND REPLACE THE COMPUTER. I'M ORDERING IT AS WE SPEAK. WILL THIS CORRECT THE PROBLEM? THE PCM IS USED AND IS "NOT STOCK TUNE". WHAT EXACTLY DOES THAT MEAN? FOR THE PRICE I CANT GO WRONG. MY UNCLE MENTIONED "FLASHING" MY PCM BUT I DONT FEEL CONFIDENT THAT'LL FIX IT. WILL I NEED TO DO ANY PROGRAMMING OF ANY SORT WHEN I INSTALL THIS USED PCM I'M GOING TO PURCHASE? OR IS IT JUST A BOLT ON PROCEDURE? LET ME KNOW ON THESE TOPICS. THANKS.
Was this
answer
helpful?
Yes
No
Monday, March 17th, 2008 AT 6:18 PM
Tiny
MASTERTECHTIM
  • MEMBER
FROM WHAT I JUST READ IN ALL DATA YOU SHOULD BE ABLE TO INSTALL IT WITHOUT PROGRAMMING IT.
Was this
answer
helpful?
Yes
No
Tuesday, March 18th, 2008 AT 7:43 AM

Please login or register to post a reply.

Recommended Guides