1999 Chevy Astro ABS and Brake light on all the time

Tiny
JOHNLAROTONDA
  • MEMBER
  • 1999 CHEVROLET ASTRO
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 135,000 MILES
I recently had my transmission replaced along with the differential, approximately 5000 miles ago. Yesterday my speedo started going crazy and the van started downshifting by itself. As I attempted to pull over I noticed that in 3rd gear and OD the van seemed to act like it was in neutral. If I would downshift manually all the gears would go in just fine except for 3rd. It would work until I got to 30mph and then act like it was in neutral again. I checked my trans fluid and its clear with not metal shavings. It even smells like new fluid. This might sound stupid, but could the ABS system have something to do with this?I have replaced everything that could go wrong with this van. Fuel pump, injectors. Etc and Im running out of money. Thanks
Do you
have the same problem?
Yes
No
Friday, October 16th, 2009 AT 11:10 AM

1 Reply

Tiny
MERLIN2021
  • EXPERT
Could be a VSS(vehicle speed sensor) on the tranny, take it back to the tranny shop. Is service engine soon light on too? If yes, Autozone reads codes for free, have that done and post all codes found. To retrieve ABS codes, you need a scantool that can read "C" codes. Autozone's tool does not do that! Check fluid level in the Master cylinder.
Was this
answer
helpful?
Yes
No
Friday, October 16th, 2009 AT 4:04 PM

Please login or register to post a reply.

Recommended Guides