Car wont start, sometimes it does, sometimes it wont.

Tiny
QAYUM
  • MEMBER
  • 1998 PROTON
  • 1.5L
  • 4 CYL
  • 2WD
  • AUTOMATIC
Hi my car sometimes can start but sometimes it doesn't. No crank, just click sound. Its like its got a mind of its own. Iv changed the battery, starter, battery cable connection and ignition switch and still the same problem occurs. There was one time the car wont start. I left it by the side of the road and came back the next day. Put the key in & it starts but my air con blower doesn't work. Drove it back home. Tried starting the car next day, it couldn't start again. On the following day, it could start and my air con blower is working fine again. Today, it wont start.

Please help. I'm running out of options. Could it be caused by faulty wiring or fuse or relay problem?
Do you
have the same problem?
Yes
No
Tuesday, March 3rd, 2015 AT 6:46 AM

3 Replies

Tiny
DR LOOT
  • EXPERT
Go to the engine control relay if you have a Mitsu ECU'd GTi, or go to the twin relay blocks
It sounds like an alarm system problem, follow the procedures below
if you have a SIEMENS ECU powered GTi engine.

Location is behind the stereo area.

Find the white wire with red trace coming off the relay (Engine Control Relay is a gold metal box for Mitsu ECU'd GTi's). Follow it along and you might see it cut and joined to a black wire - that's one of the immobiliser wires.

Now keep looking under the dash heading towards the driver, you will find the white wire with red trace connected to another black wire - that's the other side of the immobiliser.

Basically white wire with red trace is cut in from factory loom. One end goes to immobiliser switch, other end goes to immobiliser switch. The immobiliser when switched on disconnects the power that joins them together.

Simply use a wire to join both ends of the white wire with red trace back together then try starting your car.

If that don't work, then theres a 2 stage immobiliser and unfortunately haven't played around with their dash looms much more than that as only the one wire was needed on the car I did.
Was this
answer
helpful?
Yes
No
Wednesday, March 4th, 2015 AT 8:01 AM
Tiny
QAYUM
  • MEMBER
If its the immoboliser it wont start at all if im not mistaken but sometimes it can start. It like it has a mind of its own. I noticed it usually wont start if the engine is hot or on a hot day
Was this
answer
helpful?
Yes
No
Wednesday, March 4th, 2015 AT 9:04 PM
Tiny
DR LOOT
  • EXPERT
The reason I told you that it could be the immobilizer, is because that's the major complaint on all those vehicles. Sorry about that.
Was this
answer
helpful?
Yes
No
Wednesday, March 4th, 2015 AT 9:13 PM

Please login or register to post a reply.

Recommended Guides