Car shaking and stalls when I start it sometimes

Tiny
JIMMY SMITH2
  • MEMBER
  • 2001 PONTIAC GRAND PRIX
  • 199,000 MILES
I just replaced the Mass air flow sensor because the code came up it was bad. So I replaced the engine filter and boy was it old. Now the car is shaking when I put it in park it doesn't. The engine is also shaking it wasn't doing this before I replaced the mass airflow sensor and the air filter. So I bought spark plugs and wires putting them on tomorrow. Do you think that will help?


Do you
have the same problem?
Yes
No
Wednesday, July 8th, 2020 AT 6:19 PM

3 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
Are you sure the air intake tube is properly attached? Also, do me a favor. See if there are more codes and or new ones.

As far as the plugs and wires, it can never hurt. However, I don't think that is the issue since it started after the work was done. I have a feeling something is allowing unmetered air to enter the engine like a disconnected air intake between the air filter and the throttle body.

Let me know.

Joe
Was this
answer
helpful?
Yes
No
Wednesday, July 8th, 2020 AT 7:49 PM
Tiny
JIMMY SMITH2
  • MEMBER
Thank you for answering I will keep you posted.
Was this
answer
helpful?
Yes
No
Wednesday, July 8th, 2020 AT 8:32 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

Sounds like a plan. Feel free to let me know if you have other questions.

Take care,
Joe
Was this
answer
helpful?
Yes
No
Wednesday, July 8th, 2020 AT 9:46 PM

Please login or register to post a reply.

Sponsored links