CAR IDLES REALLY ROUGH AT START UP UNTIL WARMED UP

1999 Pontiac Grand Am

Tiny

Grandamkc

November, 9, 2013 AT 5:43 AM

My 99 grand am runs really rough until it warms up and then is fine. Lately when I start it, it sputters and dies. If I punch the gas quickly it comes to life. There is a fuel smell with the exhaust. I have unplugged the maf sensor and there is no change and it is clean. Egr valve seems to be ok and the passages are not blocked. I have sprayed all over with carb cleaner and haven't found any vacuum leaks. I'm at a loss! It's the 3400 engine.

FOUND 2422 RELATED QUESTIONS

6 Answers

Tiny

Wrenchtech

November, 9, 2013 AT 6:06 AM

Pull the vacuum line off the fuel pressure regulator with the engine running and see if any fuel comes out of the regulator port.

Tiny

Grandamkc

November, 9, 2013 AT 7:08 AM

Pulled the vacuum line from regulator and ran for five minutes. No fuel coming out

Tiny

Wrenchtech

November, 9, 2013 AT 7:23 AM

OK, that means it's good. You are going to need a high end scan tool to analyze the sensor data when this is happening to paint a picture of what is happening inside the engine before you can determine why it's happening.

Tiny

Grandamkc

November, 9, 2013 AT 7:26 AM

Ok this time it threw another code. A po0133 for 02 sensor bank 1. Any ideas?

Tiny

Wrenchtech

November, 9, 2013 AT 7:29 AM

That slow response in that sensor and it should be replaced but I expect you have more problems than that.

Tiny

Grandamkc

November, 9, 2013 AT 7:49 AM

Got it fixed! Put a match in the gas tank and now no more problem! Lol

Please login or register to post a reply.

Cylinder Head Valve Job Guide
Vacuum Leak Test and Repair - All Cars
Fuel Injector Replacement Ford 5.4L V8
Spark Plug Replacement Honda Element