2003 CADILLAC ESCALADE P0651

  • Tiny
  • bigDnal
  • 2003 Cadillac Escalade

Engine Performance problem
2003 Cadillac Escalade V8 Two Wheel Drive Automatic 180, 00 miles

My wives 03 Escalade has started giving us a little trouble with it's smoothness ! Running really rough at idle and in gear. My scanner coded a P0651? I have figured out what the code is but not what to do about it without the s.O.S. So to speak! Replace this and that until it's right! That can get pretty expensive on a late model Cadi!

Do you
have the same problem?
Yes
No
Saturday, November 28th, 2009 AT 11:41 PM

2 Replies

  • Tiny
  • factoryjack
  • Expert
  • 4,263 posts

The fault relates only to the 5V reference for the fuel tank pressure sensor(used for evap diagnostics), and the a/c pressure sensor. This should give no rough run, or be set by one. If you have a scan tool, does it read misfires, and is it counting any?

Was this
answer
helpful?
Yes
No
Tuesday, December 1st, 2009 AT 10:54 PM
  • Tiny
  • bigDnal
  • Member

BigDnal.
A friend and I later that night removed the computer beside the battery to find that the problem was in the connections there! After we removed the plugs to the ECM(?) We found a green carrotion around over half the prongs. We cleaned carefully and used electic contact lube and reinstalled. Then it was time for a TEST DRIVE! Black marks at the end of my road will conferm that that was indeed the problem! Thanks for your feedback though! This is a great site y'all have

Was this
answer
helpful?
Yes
No
Thursday, December 3rd, 2009 AT 5:48 AM

Please login or register to post a reply.