1990 Cadillac El Dorado My car studers when I give it gas

Tiny
JERA1040
  • MEMBER
  • 1990 CADILLAC EL DORADO
  • V8
  • FWD
  • AUTOMATIC
  • 173,000 MILES
Ok ill try this once more. I have a 1990 el dorado biaritz I love my car, but now I am to the pont of not knowing what to do. Ok first started when I try to give gas it will start to studer like. I had to take my foot off the pedal and start givin slowly in order for it not to stall. You could feel the car holding back very bad. So I did a full tune up service, they check the fuel presure and everything came ok. After I got it out it keeps doin it and now I have a anty freeze leakege. It will need a water pump replacement. My mechanic told me this could be the reason why it is acting like that. I will have it replaced and my question is if you guys have any suggestions? Coul it do that because of the water pump been broken and leaking all over under the enhgine? I could see smoke coming out of the back of the engine once I haded runin and it seems it runs all the way to the cat converter.
Do you
have the same problem?
Yes
No
Tuesday, April 7th, 2009 AT 9:42 AM

3 Replies

Tiny
FACTORYJACK
  • EXPERT
I don't see a water pump leak causing running problems unless it's overheating. It sounds like you have a misfire, or sticking egr. I can only offer suggestions as the possiblities could be numerous. If it idles fine, and stutters when you accelerate like from a stop, then I would say you have a cracked spark plug, leaking wire, faulty injector, faulty cap, or something secondary. If it feels like it is running on less than 8 cylinders at all times, you could have a fouled plug, open wire, faulty injector, valve train issue, etc. My advice is to have it looked at by a proffesional, and he should advise to put it on an ocilloscope to check the ignition pattern, and go from there.
Was this
answer
helpful?
Yes
No
Tuesday, April 7th, 2009 AT 9:52 PM
Tiny
JERA1040
  • MEMBER
I took my car for the problem above mentioned. Now I took it to a "Profesional " and the best awenser after he took 100 from me was to take it with a auto electrician. Took it didnt found nothing tokit back to another establishment and they came up with my cat converter was pluged and would replase it for 600. I shop around and found someone to put it in for me for 200. Now it is still doin the same thing. Drove it back home and the new cat was red hot and my entire underneath car was smoking bad. 2 tests with suposed specialists and no one told me near close that my gas was leaking to my cat. Now its a metter if someone can tell me please where to start again? Or what can I do? I had the problem before my ne tune up and after.
Was this
answer
helpful?
Yes
No
Tuesday, April 21st, 2009 AT 8:48 PM
Tiny
FACTORYJACK
  • EXPERT
If your converter is getting red hot, you are running severely lean. I don't know the circumstance for why no one is addressing the cause. If you took it to a professional and he said take it to an electrician, he wasn't truly a 'professional'. As I stated before, I can only offer suggestions. You could have timing chain and/or gear wear, camshaft wear, faulty oxygen sensor, worn distributor/gear, faulty ecm, poor grounds, and the list goes on. It is going to cost some $$$, maybe even more than the car is worth. And you need to find a shop that you can feel confident in spending that money with, if that is the choice.
Was this
answer
helpful?
Yes
No
Tuesday, April 21st, 2009 AT 11:48 PM

Please login or register to post a reply.

Recommended Guides