1992 Buick Regal - Error Code 41

Tiny
J_DUCHSCHER
  • MEMBER
  • 1992 BUICK REGAL
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 180,000 MILES
I have a '92 Buick Regal - 3800. Recently my check engine light has started to go on and off. Also my car has picked up an occasional hesitation (runs fine most of the time, but hesitates a little and then comes out of it). I checked the codes and came up with error code 41 (which is the cam sensor signal). I took the car to the shop and they replaced the cam sensor, timing chain, magnet…. Took the car out and the same thing. I ran the car for awhile and took it back to the shop and they did a few more things and car runs the same. This has been ongoing for a couple years. Now my car died out and want run. I’m tired of spending money at the shop and not getting results. Any ideas what it might be…ICM, Coil Packs, ECM, EGR Valve? Any assistance would be appreciated.
Do you
have the same problem?
Yes
No
Monday, April 5th, 2010 AT 1:40 PM

1 Reply

Tiny
J_DUCHSCHER
  • MEMBER
Some additional information. The spark plugs have spark when trying to start. Also, the fuel pump is working, but I'm not getting fuel to the motor.
After the car sits for an extended period of time and I try to start it, it does start for a split second and then dies and won't restart at all. If I leave it sit for awhile the same thing. Something else to note. When the car was in running condition, the colder outside the better the car ran (I'm talking like below 20 degrees), the warmer the air temp the more it picked up a hesitation. Hope this information helps.
Was this
answer
helpful?
Yes
No
Tuesday, April 6th, 2010 AT 8:18 PM

Please login or register to post a reply.

Recommended Guides